aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtwayland/APKBUILD')
-rw-r--r--community/qt5-qtwayland/APKBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/community/qt5-qtwayland/APKBUILD b/community/qt5-qtwayland/APKBUILD
index c9fbad9a8c5..9bc9ad90532 100644
--- a/community/qt5-qtwayland/APKBUILD
+++ b/community/qt5-qtwayland/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtwayland
-pkgver=5.15.3_git20210510
+pkgver=5.15.10_git20230714
pkgrel=0
-_commit="d5186701e27ad6f09f3944809cec2a25c5328026"
+_module="${pkgname#qt5-}"
+_pkgver=3a8613b91d2239aebc73b43562f929aa71af0de5
+_fullname=$_module-$_pkgver
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://www.qt.io/developers/"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
@@ -21,13 +23,23 @@ makedepends="$depends_dev
"
subpackages="$pkgname-dev"
-# Make sure this package is installed when a Qt application is installed and a
-# Wayland session is available on the system
-install_if="wayland-libs-client qt5-qtbase"
+source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz"
+builddir="$srcdir/$_fullname"
-builddir="$srcdir/qtwayland-$_commit"
+_disturl="dev.alpinelinux.org:/archive/qt/"
+snapshot() {
+ clean
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir" && cd "$srcdir"
+ git clone --filter=tree:0 https://invent.kde.org/qt/qt/$_module.git .
+ git archive --format tar --prefix=$_fullname/ $_pkgver > "$SRCDEST"/$_fullname.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$_fullname.tar
+ rsync --progress -La "$SRCDEST"/$_fullname.tar.xz $_disturl
+}
-source="https://invent.kde.org/qt/qt/qtwayland/-/archive/$_commit/qtwayland-$_commit.tar.gz"
+# Make sure this package is installed when a Qt application is installed and a
+# Wayland session is available on the system
+install_if="wayland-libs-server qt5-qtbase-x11"
prepare() {
default_prepare
@@ -53,6 +65,7 @@ package() {
find "$pkgdir/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
}
+
sha512sums="
-bbd8b427582e982c01a9510e8f4d6274639d757e428b8fdc09354cf359ec76baa56898dfbfb96f95d08acb1cf9fc93bf1fc8b831fd632e13d9ccee52295d6801 qtwayland-d5186701e27ad6f09f3944809cec2a25c5328026.tar.gz
+7714e624912ae9998f7eb7a375401eaa89e4ca82f4c2d4c8f624495ad59cf67b38980b136b41d9010604eeb2cc3de7ac3bd3c6ff0441454b4d23130a5b1ba4ac qtwayland-3a8613b91d2239aebc73b43562f929aa71af0de5.tar.xz
"