aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebchannel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtwebchannel/APKBUILD')
-rw-r--r--community/qt5-qtwebchannel/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/qt5-qtwebchannel/APKBUILD b/community/qt5-qtwebchannel/APKBUILD
index a04904d3054..59d199a11ab 100644
--- a/community/qt5-qtwebchannel/APKBUILD
+++ b/community/qt5-qtwebchannel/APKBUILD
@@ -6,12 +6,12 @@ pkgver=5.12.5
_ver=${pkgver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
-_V=${_ver/rc/RC}
+_v=${_ver/rc/RC}
pkgrel=0
pkgdesc="library for seamless integration of C++ +and QML applications with HTML/JavaScript clients."
url="http://qt-project.org/"
-arch="all"
-license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
options="!check" #upstream does not provide check
makedepends="qt5-qtbase-dev qt5-qtwebsockets-dev qt5-qtdeclarative-dev"
subpackages="$pkgname-dev"
@@ -20,14 +20,14 @@ case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
-source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz"
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/qtwebchannel-everywhere-src-$_v.tar.xz"
-builddir="$srcdir"/$_pkgname-${_V%-*}
+builddir="$srcdir"/$_pkgname-${_v%-*}
prepare() {
default_prepare
- cd "$builddir"
- mkdir -p build
+
+ mkdir -p "$builddir"/build
}
build() {