aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qt3d/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qt3d/APKBUILD')
-rw-r--r--community/qt6-qt3d/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/qt6-qt3d/APKBUILD b/community/qt6-qt3d/APKBUILD
index ec0363a7623..2c6dce29c25 100644
--- a/community/qt6-qt3d/APKBUILD
+++ b/community/qt6-qt3d/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qt3d
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics"
url="https://qt.io/"
-# s390x blocked by CMake failure
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
@@ -14,6 +16,7 @@ depends_dev="
qt6-qtshadertools-dev
"
makedepends="$depends_dev
+ assimp-dev
cmake
perl
samurai
@@ -30,6 +33,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qt3d-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -42,5 +47,5 @@ package() {
}
sha512sums="
-14fcd607fc6d93f8c97142f6bbb62ec4b7ff108c3233cdb919de1382a21b29aa901a82c5b6d1a0244b3a863e713ba42f65efc21b2eb807cbe0e007b5be17fea9 qt3d-everywhere-src-6.3.0.tar.xz
+de47d1131fb4219481cb59d3b61f9f06b3785ac429d267da197d637fde1c72b6f8a0633bf1b6e4469dd22c95f2f2fd70f5eadc3b7d7e6324fad764271f741b71 qt3d-everywhere-src-6.6.3.tar.xz
"