aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qt5compat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qt5compat/APKBUILD')
-rw-r--r--community/qt6-qt5compat/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/community/qt6-qt5compat/APKBUILD b/community/qt6-qt5compat/APKBUILD
index 22a726e13c0..ba51dd18829 100644
--- a/community/qt6-qt5compat/APKBUILD
+++ b/community/qt6-qt5compat/APKBUILD
@@ -1,17 +1,25 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qt5compat
-pkgver=6.1.2
+pkgver=6.6.3
pkgrel=0
pkgdesc="Module that contains unsupported Qt 5 APIs"
url="https://qt.io/"
arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+# icu-data-full: see https://gitlab.alpinelinux.org/alpine/aports/-/issues/13814
+# qt6-qt5compat provides the same icu mib apis
+depends="icu-data-full"
depends_dev="
qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -25,8 +33,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qt5compat-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -36,5 +46,5 @@ package() {
}
sha512sums="
-643c7ae1c9e9e60becfd083fb1d88a3dde58bdf2bd5706ff4832a76f416f0bfae197e7a22198a61df7a966f99a55a030dc30fa3abd6814fae1df2077f5329da9 qt5compat-everywhere-src-6.1.2.tar.xz
+11a1e03216c434c07ff984fc7f225072067bd17f1d469513e84d610d067953ad8f0e492973cfab3afbaaadffd5b1d0db3e84cc96f1abfad4fced0ee852729330 qt5compat-everywhere-src-6.6.3.tar.xz
"