aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qt5compat
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qt5compat')
-rw-r--r--community/qt6-qt5compat/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/qt6-qt5compat/APKBUILD b/community/qt6-qt5compat/APKBUILD
new file mode 100644
index 00000000000..ba51dd18829
--- /dev/null
+++ b/community/qt6-qt5compat/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
+pkgname=qt6-qt5compat
+pkgver=6.6.3
+pkgrel=0
+pkgdesc="Module that contains unsupported Qt 5 APIs"
+url="https://qt.io/"
+arch="all"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+# icu-data-full: see https://gitlab.alpinelinux.org/alpine/aports/-/issues/13814
+# qt6-qt5compat provides the same icu mib apis
+depends="icu-data-full"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ cmake
+ perl
+ samurai
+ "
+subpackages="$pkgname-dev"
+options="!check" # No tests
+builddir="$srcdir/qt5compat-everywhere-src-${pkgver/_/-}"
+
+case $pkgver in
+ *_alpha*|*_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
+esac
+
+source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qt5compat-everywhere-src-${pkgver/_/-}.tar.xz"
+
+build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+11a1e03216c434c07ff984fc7f225072067bd17f1d469513e84d610d067953ad8f0e492973cfab3afbaaadffd5b1d0db3e84cc96f1abfad4fced0ee852729330 qt5compat-everywhere-src-6.6.3.tar.xz
+"