aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtbase/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtbase/APKBUILD')
-rw-r--r--community/qt6-qtbase/APKBUILD52
1 files changed, 34 insertions, 18 deletions
diff --git a/community/qt6-qtbase/APKBUILD b/community/qt6-qtbase/APKBUILD
index 2a327ef154c..d5bc7fd6a53 100644
--- a/community/qt6-qtbase/APKBUILD
+++ b/community/qt6-qtbase/APKBUILD
@@ -1,7 +1,10 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtbase
-pkgver=6.3.0
-pkgrel=1
+pkgver=6.6.3
+pkgrel=0
pkgdesc="A cross-platform application and UI framework"
url="https://qt.io/"
arch="all"
@@ -13,7 +16,6 @@ _sub="
$pkgname-sqlite
$pkgname-x11
"
-depends="xdg-utils"
depends_dev="$_sub
cups-dev
dbus-dev
@@ -34,7 +36,7 @@ depends_dev="$_sub
libxkbcommon-dev
mariadb-dev
mesa-dev
- openssl1.1-compat-dev
+ openssl-dev>3
pcre2-dev
sqlite-dev
tslib-dev
@@ -42,6 +44,7 @@ depends_dev="$_sub
vulkan-headers
vulkan-loader-dev
wayland-dev
+ xcb-util-cursor-dev
xcb-util-dev
xcb-util-image-dev
xcb-util-keysyms-dev
@@ -64,19 +67,28 @@ case $pkgver in
esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtbase-everywhere-src-${pkgver/_/-}.tar.xz
- qtbug-102177.patch
+ 0001-lfs64.patch
"
-case "$CTARGET_ARCH" in
- arm*|aarch64) _opengl="-DQT_FEATURE_opengles2=ON" ;;
-esac
-
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+# secfixes:
+# 6.5.0-r5:
+# - CVE-2023-32762
+# - CVE-2023-32763
build() {
- cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ case "$CTARGET_ARCH" in
+ arm*|aarch64)
+ local opengl="-DQT_FEATURE_opengles2=ON"
+ ;;
+ esac
+
+ # -g1: significantly reduce debug symbol size
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DINSTALL_BINDIR=lib/qt6/bin \
-DINSTALL_PUBLICBINDIR=usr/bin \
-DINSTALL_DOCDIR=share/doc/qt6 \
@@ -86,11 +98,15 @@ build() {
-DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
-DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
-DQT_FEATURE_journald=OFF \
+ -DFEATURE_libproxy=ON \
-DQT_FEATURE_openssl_linked=ON \
+ -DQT_FEATURE_reduce_relocations=OFF \
-DQT_FEATURE_system_sqlite=ON \
+ -DQT_FEATURE_system_xcb_xinput=ON \
-DQT_FEATURE_vulkan=ON \
- $_opengl
- cmake --build build --parallel
+ -DQT_FEATURE_xcb=ON \
+ $opengl
+ cmake --build build
}
check() {
@@ -104,7 +120,7 @@ package() {
# add symlinks for qt6 dev tools
cd "$pkgdir"
mkdir -p usr/bin
- while read _line; do
+ while read -r _line; do
ln -sv $_line
done < "$builddir"/build/user_facing_tool_links.txt
}
@@ -142,7 +158,7 @@ mysql() {
x11() {
pkgdesc="Qt6 GUI-related libraries"
- depends="hicolor-icon-theme"
+ depends="hicolor-icon-theme xdg-utils"
cd "$pkgdir"
amove \
usr/lib/libQt6EglFSDeviceIntegration.so.* \
@@ -161,6 +177,6 @@ x11() {
}
sha512sums="
-aec9f7cee0c195178a282ab3efa6b3dd09dbe3317ec25c8f748c6cc0ea1ffe37dc62d3b062129d2458179620059e8bb694aacd1e331cbf49838075fa3381ee81 qtbase-everywhere-src-6.3.0.tar.xz
-885530936651a5d79920a0e0176a4b898b0a500a967a4b3dc1e5b61d9a767cbc60de3cdbf02ad0c936a9456112d08211f708d6327c04544942b8c64600c664d9 qtbug-102177.patch
+cd96903a3947a1f5cf6a3ff21ab0b3209ed421d2a8c45acb34ae5aa7ad0501cb79e26cfa81bc02141d5731ebfa662442f37806e97994332077d963c9e70a5f54 qtbase-everywhere-src-6.6.3.tar.xz
+390e2998483696e4af6f754be6611eb01f93b5185e81f8ad21c45cd267bab58a347902230b456b4c9fae339d6b8ecb6f7cf695e90fb086d92b9c5f7561993898 0001-lfs64.patch
"