aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtconnectivity/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtconnectivity/APKBUILD')
-rw-r--r--community/qt6-qtconnectivity/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/qt6-qtconnectivity/APKBUILD b/community/qt6-qtconnectivity/APKBUILD
index 6a3c12ca2df..b026767026b 100644
--- a/community/qt6-qtconnectivity/APKBUILD
+++ b/community/qt6-qtconnectivity/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtconnectivity
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides access to Bluetooth hardware"
url="https://qt.io/"
-# s390x blocked by qt6-qtdeclarative
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
bluez-dev
@@ -29,6 +31,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtconnectivity-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -51,5 +55,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-b666d46cb599d88df881f78a7cbe20bc1e7845d1295a0cdd77fc4124b938dab7ae9fc0e4be401e3a10f519b9d87941ab438baadc53ff657d1217c6a4ec27bb8d qtconnectivity-everywhere-src-6.3.0.tar.xz
+e75eea3d9c95532dafd3e2c765b1109f066e4b583d00205d18655e39f43f7373122e4d014d405d655d12b2246470083f1ac5dada0698bc1b0fb1d115a9fca6ea qtconnectivity-everywhere-src-6.6.3.tar.xz
"