aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtdeclarative/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtdeclarative/APKBUILD')
-rw-r--r--community/qt6-qtdeclarative/APKBUILD40
1 files changed, 31 insertions, 9 deletions
diff --git a/community/qt6-qtdeclarative/APKBUILD b/community/qt6-qtdeclarative/APKBUILD
index da1c1399615..f0497189490 100644
--- a/community/qt6-qtdeclarative/APKBUILD
+++ b/community/qt6-qtdeclarative/APKBUILD
@@ -1,18 +1,26 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtdeclarative
-pkgver=6.1.2
+pkgver=6.6.3
pkgrel=0
pkgdesc="Classes for QML and JavaScript languages"
url="https://qt.io/"
arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
- qt6-qtbase-dev
+ qt6-qtshadertools-dev
vulkan-headers
"
-makedepends="$depends_dev
+makedepends="
+ $depends_dev
cmake
+ lttng-ust-dev
perl
+ qt6-qtbase-dev
+ qt6-qtlanguageserver-dev
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -25,29 +33,43 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtdeclarative-everywhere-src-${pkgver/_/-}.tar.xz"
-_qt6_prefix=/usr/lib/qt6
+_qt6_prefix=usr/lib/qt6
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export PATH="$PATH:/usr/lib/qt6/bin"
+ export CFLAGS="$CFLAGS -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DINSTALL_PUBLICBINDIR=usr/bin \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # install symlinks for user-facing tools
+ cd "$pkgdir"
+ mkdir -p usr/bin
+ local line
+ while read -r line; do
+ ln -sfv $line
+ done < "$builddir"/build/user_facing_tool_links.txt
}
dev() {
default_dev
+ # move created symlinks- all dev binaries
+ amove usr/bin
+
find "$pkgdir"/"$_qt6_prefix"/bin/ -type f -not -name "qmlscene" | while read -r f; do
file=$(basename $f)
- amove "${_qt6_prefix#/}"/bin/$file
+ amove "$_qt6_prefix"/bin/$file
done
}
-
sha512sums="
-653f902762943643262d3575bb918bf04b4cab156b17f5e6d5fd0132fed059d578cbf60a0b7cc25051aad73c2cbbf17d33f709377d076fd402792b3e213f66e7 qtdeclarative-everywhere-src-6.1.2.tar.xz
+78b19353ddc447dc2b850987ee1e9fe5c898c641190fdc45001369d3d08487d62b3a20f22532c9bd9a365d3e2fcb910091001c7766142c4c6c510ac61c6a6fca qtdeclarative-everywhere-src-6.6.3.tar.xz
"