aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtlottie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtlottie/APKBUILD')
-rw-r--r--community/qt6-qtlottie/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/qt6-qtlottie/APKBUILD b/community/qt6-qtlottie/APKBUILD
index e40b8acb9c1..bb56d73bfb7 100644
--- a/community/qt6-qtlottie/APKBUILD
+++ b/community/qt6-qtlottie/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtlottie
-pkgver=6.1.2
+pkgver=6.6.3
pkgrel=0
pkgdesc="A family of player software for a certain json-based file format for describing 2d vector graphics animations"
url="https://qt.io/"
@@ -14,6 +17,7 @@ depends_dev="
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -27,8 +31,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtlottie-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -38,5 +44,5 @@ package() {
}
sha512sums="
-286d241f3c6fe0134d7bbe83bbcfb17efe72d187e7a6a0dcb7c5de6dfbfc7c0bb430ead3e4e9d9faf1cc3e850a291a5be09dfd830912f12e3004a05aa28d0add qtlottie-everywhere-src-6.1.2.tar.xz
+4ea0c56d5c2d12bda1d3ee0e5d820000f8ebef36ca957d69de9f40180cb07dab4f2301b4e3b06a01e33339da4b326a26d7d43de8566e6c42a42b322aeaf32a4b qtlottie-everywhere-src-6.6.3.tar.xz
"