aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtnetworkauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtnetworkauth/APKBUILD')
-rw-r--r--community/qt6-qtnetworkauth/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/qt6-qtnetworkauth/APKBUILD b/community/qt6-qtnetworkauth/APKBUILD
index 6da6b4133a5..6c5297f4f28 100644
--- a/community/qt6-qtnetworkauth/APKBUILD
+++ b/community/qt6-qtnetworkauth/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtnetworkauth
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Network authentication module"
url="https://qt.io/"
@@ -27,6 +30,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtnetworkauth-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -38,5 +43,5 @@ package() {
}
sha512sums="
-b37910efae4d0ebc97e207067b2add07938e412f00c4447250e2426a166e31be314f68d2b89f0b13cbb484014d3d8d08aa6daf5985174fde69608ad5e6e2f4fc qtnetworkauth-everywhere-src-6.3.0.tar.xz
+c9976ab38f8a28a5944a70c6312490df9d3823d2125fe7a23aa8752a2d5dc9c2a7bc5f256f7e95acd475806cb64fcb703ae1f633311d8f03f690e87b2de49f8e qtnetworkauth-everywhere-src-6.6.3.tar.xz
"