aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtnetworkauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtnetworkauth/APKBUILD')
-rw-r--r--community/qt6-qtnetworkauth/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/qt6-qtnetworkauth/APKBUILD b/community/qt6-qtnetworkauth/APKBUILD
index 51af3593921..af8a80e97fa 100644
--- a/community/qt6-qtnetworkauth/APKBUILD
+++ b/community/qt6-qtnetworkauth/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtnetworkauth
-pkgver=6.2.0
+pkgver=6.6.2
pkgrel=0
pkgdesc="Network authentication module"
url="https://qt.io/"
@@ -13,6 +16,7 @@ depends_dev="
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -26,8 +30,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtnetworkauth-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -37,5 +43,5 @@ package() {
}
sha512sums="
-64234f7db0abb9d445099fd7bc2fa1dd9a5f740329c9a593bd8aff5fe6333ae2407506e4b8e657306ac79a3a03990fd940a2a09807837df8baea2d0abdd328e5 qtnetworkauth-everywhere-src-6.2.0.tar.xz
+1fff9c52d47c8f97569bf201aa3051da57dbcf10f63c7e7334286b40042b6437f9636f8fd1db3a8d1a519036dae162ae57d6a24908441df84003134cfdb5cfd3 qtnetworkauth-everywhere-src-6.6.2.tar.xz
"