aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtpositioning/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtpositioning/APKBUILD')
-rw-r--r--community/qt6-qtpositioning/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/qt6-qtpositioning/APKBUILD b/community/qt6-qtpositioning/APKBUILD
index 864f9b0ad40..ad258e95980 100644
--- a/community/qt6-qtpositioning/APKBUILD
+++ b/community/qt6-qtpositioning/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtpositioning
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides access to position, satellite and area monitoring classes"
url="https://qt.io/"
-# s390x blocked by qt6-qtdeclarative
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends="xdg-utils"
depends_dev="
@@ -28,11 +30,9 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtpositioning-everywhere-src-${pkgver/_/-}.tar.xz"
-# Backwards compatibility
-provides="qt6-qtlocation=$pkgver-r$pkgrel"
-replaces="qt6-qtlocation"
-
build() {
+ export CFLAGS="$CFLAGS -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -55,5 +55,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-bd59ca0a724cb4f66052999d519352c7d2619878f9edd93f5c61a677871c543dcd5221a42af392083738cd6359e4a365e782f6bce66b475f79da6a0daf5d07ba qtpositioning-everywhere-src-6.3.0.tar.xz
+6ae48b27851a18c44fa3167fa05d7da9b885a85e8b99c2efc750092d1bc0bc2c438b10e085486fce143b4f961189be843fd1a58581d31bd212e79596ce52a686 qtpositioning-everywhere-src-6.6.3.tar.xz
"