aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtquicktimeline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtquicktimeline/APKBUILD')
-rw-r--r--community/qt6-qtquicktimeline/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/qt6-qtquicktimeline/APKBUILD b/community/qt6-qtquicktimeline/APKBUILD
index d74b0522503..399c18811c0 100644
--- a/community/qt6-qtquicktimeline/APKBUILD
+++ b/community/qt6-qtquicktimeline/APKBUILD
@@ -1,6 +1,9 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtquicktimeline
-pkgver=6.1.2
+pkgver=6.6.3
pkgrel=0
pkgdesc="Qt module for keyframe-based timeline construction"
url="https://qt.io/"
@@ -14,6 +17,7 @@ depends_dev="
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -27,8 +31,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtquicktimeline-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -38,5 +44,5 @@ package() {
}
sha512sums="
-2fe8af00cc32cbbde01655cd8a8d0aca98710bd356e062bdad8c7cd3f1f84e56e6cfe196caa4204005176ee0872227daceb4fcea4c3171dc82d04b80e01f8f77 qtquicktimeline-everywhere-src-6.1.2.tar.xz
+1e0976a34496f3961f958a38296b1aebf5bb0be7e077b70a91d93ff4e2c652b09ba5cdf94e26c748988ce489d025328a0bd9feca77bc2ddfb360815682055e47 qtquicktimeline-everywhere-src-6.6.3.tar.xz
"