aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtremoteobjects/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtremoteobjects/APKBUILD')
-rw-r--r--community/qt6-qtremoteobjects/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/qt6-qtremoteobjects/APKBUILD b/community/qt6-qtremoteobjects/APKBUILD
index 57d016ed246..85be455990b 100644
--- a/community/qt6-qtremoteobjects/APKBUILD
+++ b/community/qt6-qtremoteobjects/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtremoteobjects
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Inter-process communication (IPC) module developed for Qt"
url="https://qt.io/"
-# s390x blocked by qt6-qtremoteobjects
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
@@ -28,6 +30,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtremoteobjects-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -50,5 +54,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-91e7d2f0be8804fd239ea3d569937cc3a9f1c679ec7f5a9ce51905a05f27a2dc91caca164f9e1a9af5e7c0d7d30f4dcda0df91a5b24a877cd42be90e4807a553 qtremoteobjects-everywhere-src-6.3.0.tar.xz
+4cf25b3b6d8574ebd0028b605a96c74737f35895ffe267b8986e2145c180f383e4c21002a18fa45ded11610f6f54775893f7af8ac22d0006a5f127e7e93e85ae qtremoteobjects-everywhere-src-6.6.3.tar.xz
"