aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtscxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtscxml/APKBUILD')
-rw-r--r--community/qt6-qtscxml/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/qt6-qtscxml/APKBUILD b/community/qt6-qtscxml/APKBUILD
index aa721a51ee4..734e8ab5eac 100644
--- a/community/qt6-qtscxml/APKBUILD
+++ b/community/qt6-qtscxml/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtscxml
-pkgver=6.1.2
+pkgver=6.6.3
pkgrel=0
pkgdesc="Static and runtime integration of SCXML models into Qt6 code"
url="https://qt.io/"
@@ -14,6 +17,7 @@ depends_dev="
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
@@ -27,8 +31,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtscxml-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -38,5 +44,5 @@ package() {
}
sha512sums="
-40f17034c6101339c1d2ec84468f4a19a4d51fe3a5d262b3d9259f03b116280fe0e5640c3c09ed09f5b92b80ee2cb82b238931d7ffc37ca2294fbe92215a4b52 qtscxml-everywhere-src-6.1.2.tar.xz
+626efd53f5f54d1742b86e95c8eb240354a88492601fc650bde0229670a1c75a009320ebf50b135634a3deaddb111ddffd878e392b806f723f8b0e965dacb270 qtscxml-everywhere-src-6.6.3.tar.xz
"