aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtserialport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtserialport/APKBUILD')
-rw-r--r--community/qt6-qtserialport/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/qt6-qtserialport/APKBUILD b/community/qt6-qtserialport/APKBUILD
new file mode 100644
index 00000000000..a36926d0fb4
--- /dev/null
+++ b/community/qt6-qtserialport/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
+pkgname=qt6-qtserialport
+pkgver=6.6.3
+pkgrel=0
+pkgdesc="Provides access to hardware and virtual serial ports"
+url="https://qt.io/"
+arch="all"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+depends_dev="qt6-qtbase-dev"
+makedepends="$depends_dev
+ cmake
+ perl
+ samurai
+ "
+subpackages="$pkgname-dev"
+builddir="$srcdir/qtserialport-everywhere-src-${pkgver/_/-}"
+
+case $pkgver in
+ *_alpha*|*_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
+esac
+
+source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtserialport-everywhere-src-${pkgver/_/-}.tar.xz"
+
+build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_BINDIR=lib/qt6/bin \
+ -DINSTALL_DOCDIR=share/doc/qt6 \
+ -DINSTALL_ARCHDATADIR=lib/qt6 \
+ -DINSTALL_DATADIR=share/qt6 \
+ -DINSTALL_INCLUDEDIR=include/qt6 \
+ -DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
+ -DINSTALL_EXAMPLESDIR=share/doc/qt6/examples
+ cmake --build build --parallel
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+sha512sums="
+b5a92452889f6fdcf05bd9395b803557ade0df60b49c698d7131df611cde1980d0b957127034aa6aae23f24dec6e97dff129c60e5d0291f057ba6d9fb51dcfca qtserialport-everywhere-src-6.6.3.tar.xz
+"