aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qttranslations/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qttranslations/APKBUILD')
-rw-r--r--community/qt6-qttranslations/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/qt6-qttranslations/APKBUILD b/community/qt6-qttranslations/APKBUILD
new file mode 100644
index 00000000000..dd798c2ee17
--- /dev/null
+++ b/community/qt6-qttranslations/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
+pkgname=qt6-qttranslations
+pkgver=6.6.3
+pkgrel=0
+pkgdesc="A cross-platform application and UI framework (Translations)"
+url="https://qt.io/"
+arch="noarch"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+makedepends="
+ cmake
+ perl
+ qt6-qtbase-dev
+ qt6-qttools-dev
+ samurai
+ "
+builddir="$srcdir/qttranslations-everywhere-src-${pkgver/_/-}"
+options="!check" # No tests
+
+case $pkgver in
+ *_alpha*|*_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
+esac
+
+source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qttranslations-everywhere-src-${pkgver/_/-}.tar.xz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ # -j1 to prevent race conditions and missing translation files
+ cmake --build build -j1
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+b764161def8d9e7f1f7e6417dc37e166cde402642234f8a3b55f93a56ef2f46c68799d4e80c283fe76f9790b3d84274e6be680189bc04cc09fa8ca2ea68397e7 qttranslations-everywhere-src-6.6.3.tar.xz
+"