aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtwayland/APKBUILD')
-rw-r--r--community/qt6-qtwayland/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/qt6-qtwayland/APKBUILD b/community/qt6-qtwayland/APKBUILD
index a3fcc669e4f..2a7ec7d3be0 100644
--- a/community/qt6-qtwayland/APKBUILD
+++ b/community/qt6-qtwayland/APKBUILD
@@ -1,11 +1,13 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtwayland
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides APIs for Wayland"
url="https://qt.io/"
-# s390x and armhf blocked by qt6-qtdeclarative
-arch="all !s390x !armhf"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
@@ -21,6 +23,10 @@ subpackages="$pkgname-dev"
options="!check" # No tests
builddir="$srcdir/qtwayland-everywhere-src-${pkgver/_/-}"
+# Make sure this package is installed when a Qt application is installed and a
+# Wayland session is available on the system
+install_if="wayland-libs-server qt6-qtbase-x11"
+
case $pkgver in
*_alpha*|*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
@@ -29,6 +35,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtwayland-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -40,5 +48,5 @@ package() {
}
sha512sums="
-0c64b114c5b3edd2b278f03dbc46aa1907e5accf4c9512cc0b594f6a58571eb023541a3bc0185aec24367d9e6e675e32999bc5ac4f0ac671b09100e86add4cd6 qtwayland-everywhere-src-6.3.0.tar.xz
+6829c9aef2b7fc37a6a94c0093d478c13742d8c2b3d2b9444b7a1dbe022bfce1f6a5665d16bebe221e93bddd964b726451b2949352877b25d65654df17a58eb1 qtwayland-everywhere-src-6.6.3.tar.xz
"