aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtwayland/APKBUILD')
-rw-r--r--community/qt6-qtwayland/APKBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/community/qt6-qtwayland/APKBUILD b/community/qt6-qtwayland/APKBUILD
index 121e64cede0..2a7ec7d3be0 100644
--- a/community/qt6-qtwayland/APKBUILD
+++ b/community/qt6-qtwayland/APKBUILD
@@ -1,6 +1,9 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtwayland
-pkgver=6.1.1
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides APIs for Wayland"
url="https://qt.io/"
@@ -8,16 +11,22 @@ arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
+ qt6-qtdeclarative-dev
vulkan-headers
"
makedepends="$depends_dev
cmake
perl
+ samurai
"
subpackages="$pkgname-dev"
options="!check" # No tests
builddir="$srcdir/qtwayland-everywhere-src-${pkgver/_/-}"
+# Make sure this package is installed when a Qt application is installed and a
+# Wayland session is available on the system
+install_if="wayland-libs-server qt6-qtbase-x11"
+
case $pkgver in
*_alpha*|*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
@@ -26,8 +35,10 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtwayland-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -37,5 +48,5 @@ package() {
}
sha512sums="
-fe467e2332e2f00f929b3d91b1b8e42ee657b194114e59eaf06fb78f26c904ddc946099ce1b2b17ecdac0a41b9df3409a0c11296a6b0b19dbe75f2e513276406 qtwayland-everywhere-src-6.1.1.tar.xz
+6829c9aef2b7fc37a6a94c0093d478c13742d8c2b3d2b9444b7a1dbe022bfce1f6a5665d16bebe221e93bddd964b726451b2949352877b25d65654df17a58eb1 qtwayland-everywhere-src-6.6.3.tar.xz
"