aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtwebchannel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtwebchannel/APKBUILD')
-rw-r--r--community/qt6-qtwebchannel/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/qt6-qtwebchannel/APKBUILD b/community/qt6-qtwebchannel/APKBUILD
index 0d4b1451b8c..c89ac286c8e 100644
--- a/community/qt6-qtwebchannel/APKBUILD
+++ b/community/qt6-qtwebchannel/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtwebchannel
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides access to QObject or QML objects from HTML clients"
url="https://qt.io/"
-# s390x blocked by qt6-qtdeclarative
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
@@ -29,6 +31,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtwebchannel-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -51,5 +55,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-350892766af486f5f1d6925f156342c4958ce8a86ecd018f65f533af56f62c097d220dc59fa7d169206edb489134cebd7e5b247181d8111ca90630ddf603ca22 qtwebchannel-everywhere-src-6.3.0.tar.xz
+81b264aa661460b7872bfdf49b4404f090382346997ee288afc8c00a92c52a72d963cba9667ef99e02b8bd696456ee34e811e5885ed5d400076cdcc1e6cf72fa qtwebchannel-everywhere-src-6.6.3.tar.xz
"