aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtwebsockets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt6-qtwebsockets/APKBUILD')
-rw-r--r--community/qt6-qtwebsockets/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/community/qt6-qtwebsockets/APKBUILD b/community/qt6-qtwebsockets/APKBUILD
index c60187e1826..3d38652e22e 100644
--- a/community/qt6-qtwebsockets/APKBUILD
+++ b/community/qt6-qtwebsockets/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=qt6
pkgname=qt6-qtwebsockets
-pkgver=6.3.0
+pkgver=6.6.3
pkgrel=0
pkgdesc="Provides WebSocket communication compliant with RFC 6455"
url="https://qt.io/"
-# s390x blocked by qt6-qtdeclarative-dev
-arch="all !s390x"
+arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
qt6-qtbase-dev
@@ -17,7 +19,9 @@ makedepends="$depends_dev
perl
samurai
"
-subpackages="$pkgname-dev"
+# needs a .so from the main package
+depends_dev="$depends_dev $pkgname=$pkgver-r$pkgrel"
+subpackages="$pkgname-dev $pkgname-libs"
builddir="$srcdir/qtwebsockets-everywhere-src-${pkgver/_/-}"
case $pkgver in
@@ -28,6 +32,8 @@ esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtwebsockets-everywhere-src-${pkgver/_/-}.tar.xz"
build() {
+ export CFLAGS="$CFLAGS -g1 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -g1 -flto=auto"
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -49,6 +55,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-61ea5f6fbc1c416023aa8b2e34f1e0fcac84807b75010a37ee3d7fb63ef493273cda8d450ec5ef4ff08ac2edaf8ea61459dec75ec5a96774657f9b4604576fd8 qtwebsockets-everywhere-src-6.3.0.tar.xz
+d9d6ab3380dfd0f74dc5c37d9aedcbd3349535d97f732e1fd6adef9a8d7ca3eb5a99b0cf94d0b7dafccd910689b82c0e2fcb631b3befe89e04778f92612d0190 qtwebsockets-everywhere-src-6.6.3.tar.xz
"