aboutsummaryrefslogtreecommitdiffstats
path: root/community/radare2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/radare2/APKBUILD')
-rw-r--r--community/radare2/APKBUILD148
1 files changed, 126 insertions, 22 deletions
diff --git a/community/radare2/APKBUILD b/community/radare2/APKBUILD
index a78878b6037..ed4fca714d6 100644
--- a/community/radare2/APKBUILD
+++ b/community/radare2/APKBUILD
@@ -4,21 +4,106 @@
# Contributor: Jose-Luis Rivas <ghostbar@riseup.net>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=radare2
-pkgver=5.6.8
-pkgrel=0
-pkgdesc="An opensource, crossplatform reverse engineering framework"
-url="http://www.radare.org"
+pkgver=5.8.8
+pkgrel=1
+pkgdesc="Opensource, crossplatform reverse engineering framework"
+url="https://www.radare.org/"
arch="all"
-license="GPL-3.0"
+license="GPL-3.0-or-later AND LGPL-2.0-or-later AND LGPL-2.1-or-later"
options="net !check" # upstream does not provide any working testsuite
-makedepends="$depends_dev libzip-dev openssl1.1-compat-dev capstone-dev linux-headers"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-libs"
-source="$pkgname-$pkgver-r$pkgrel.tar.gz::https://github.com/radare/radare2/archive/$pkgver.tar.gz
+makedepends="
+ capstone-dev
+ file-dev
+ libzip-dev
+ linux-headers
+ lz4-dev
+ meson
+ xxhash-dev
+ zlib-dev
+ "
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-libs
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/radare/radare2/archive/$pkgver.tar.gz
string-header-build-fix.patch"
# secfixes:
+# 5.8.2-r0:
+# - CVE-2023-0302
+# 5.8.0-r0:
+# - CVE-2022-4398
+# 5.7.2-r0:
+# - CVE-2022-34520
+# - CVE-2022-34502
+# 5.7.0-r0:
+# - CVE-2022-1437
+# - CVE-2022-1444
+# - CVE-2022-1451
+# - CVE-2022-1452
+# - CVE-2022-1649
+# - CVE-2022-1714
+# - CVE-2022-1809
+# - CVE-2022-1899
+# 5.6.8-r0:
+# - CVE-2022-1061
+# - CVE-2022-1207
+# - CVE-2022-1237
+# - CVE-2022-1238
+# - CVE-2022-1244
+# - CVE-2022-1283
+# - CVE-2022-1284
+# - CVE-2022-1296
+# - CVE-2022-1297
+# - CVE-2022-1382
+# - CVE-2022-1383
+# 5.6.6-r0:
+# - CVE-2022-0849
+# - CVE-2022-1031
+# - CVE-2022-1052
+# - CVE-2022-1240
+# 5.6.4-r0:
+# - CVE-2022-0476
+# - CVE-2022-0676
+# - CVE-2022-0695
+# - CVE-2022-0712
+# - CVE-2022-0713
+# 5.6.2-r0:
+# - CVE-2022-0518
+# - CVE-2022-0519
+# - CVE-2022-0520
+# - CVE-2022-0521
+# - CVE-2022-0522
+# - CVE-2022-0523
+# - CVE-2022-0559
+# 5.6.0-r0:
+# - CVE-2022-0139
+# - CVE-2022-0173
+# - CVE-2022-0419
+# 5.5.4-r0:
+# - CVE-2021-44974
+# - CVE-2021-44975
+# 5.5.2-r0:
+# - CVE-2021-4021
+# 5.4.0-r0:
+# - CVE-2021-3673
+# 5.3.1-r0:
+# - CVE-2021-32613
+# 4.5.1-r0:
+# - CVE-2020-16269
+# - CVE-2020-17487
# 4.5.0-r0:
# - CVE-2020-15121
+# 4.4.0-r0:
+# - CVE-2020-27793
+# - CVE-2020-27794
+# - CVE-2020-27795
+# 4.0.0-r0:
+# - CVE-2019-19590
+# - CVE-2019-19647
# 3.9.0-r0:
# - CVE-2019-14745
# - CVE-2019-12865
@@ -27,26 +112,45 @@ source="$pkgname-$pkgver-r$pkgrel.tar.gz::https://github.com/radare/radare2/arch
# - CVE-2019-12790
build() {
- [ "$CARCH" = "s390x" ] && _disable_debugger="--disable-debugger"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
+ local _disable_debugger=
+ if [ "$CARCH" = "s390x" ]; then
+ _disable_debugger="-Ddebugger=false"
+ fi
+
+ abuild-meson \
$_disable_debugger \
- --with-syscapstone \
- --with-openssl \
- --with-syszip
- make HAVE_LIBVERSION=1
+ -Duse_sys_magic=true \
+ -Duse_sys_zlib=true \
+ -Duse_sys_lz4=true \
+ -Duse_sys_xxhash=true \
+ -Duse_sys_zip=true \
+ -Duse_sys_capstone=true \
+ -Dwant_capstone=true \
+ . output
+ meson compile -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ # Install additional documentation files
+ for file in doc/*; do
+ if [ -f "$file" ]; then
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname "$file"
+ fi
+ done
+
+ # Create soname.major.minor symlinks which the meson build
+ # system doesn't create by default (GNU autotools did though).
+ for file in "$pkgdir"/usr/lib/libr_*.so.?.?.?; do
+ name=${file##*/} # basename with major.minor.patch
+ major=${name%.*} # basename with major.minor
+
+ ln -s "$name" "$pkgdir/usr/lib/$major"
+ done
}
sha512sums="
-e29a3ff235f37bcde4ec6c1c97d1b9c521b57e93512ca40d71be9e88ac1c002f41af905865fdf4685ee94287425cff32500b5a111eec5594bdd7f32f05631910 radare2-5.6.8-r0.tar.gz
+38f3373cc3029a7d92e1ae44ab515f0bea4c897cb981a904b40a7e05c04c29786dc8ac2f46fc97b495c4a2ec4905e0e196633dd3144c557c550239c462c9360b radare2-5.8.8.tar.gz
5e60a1112a10cdd6a31374ba9b564d6522a37086380cf74b7232e32fb700ae1b2f68edbc0726ebedcc31d4789bc4f89525f117f25dac3609c60a75d471e49c85 string-header-build-fix.patch
"