aboutsummaryrefslogtreecommitdiffstats
path: root/community/raft/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/raft/APKBUILD')
-rw-r--r--community/raft/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/raft/APKBUILD b/community/raft/APKBUILD
index 10baa40d3fb..667c4ac8058 100644
--- a/community/raft/APKBUILD
+++ b/community/raft/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=raft
-pkgver=0.13.0
+pkgver=0.18.1
pkgrel=0
pkgdesc="C implementation of the Raft consensus protocol"
url="https://github.com/canonical/raft"
@@ -10,7 +10,8 @@ license="LGPL-3.0-only WITH LGPL-3.0-linking-exception"
makedepends="linux-headers libuv-dev autoconf automake libtool"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/canonical/raft/archive/v$pkgver.tar.gz
- unistd-include.patch"
+ unistd-include.patch
+ disable-bind-address-test-segfaulting.patch"
prepare() {
default_prepare
@@ -20,13 +21,16 @@ prepare() {
build() {
./configure \
--prefix=/usr \
- --disable-lz4 \
+ --without-lz4 \
--enable-example=no
make
}
check() {
- make check
+ make check || {
+ cat ./test-suite.log
+ return 1
+ }
}
package() {
@@ -35,6 +39,7 @@ package() {
}
sha512sums="
-1d65f21ac85deb36a6f8681bd506656a34994164ba51f7c23aa523673024dacf5616bbb3f706c0da4df38c0cc1a00b330459209c80d404545686525da2916afa raft-0.13.0.tar.gz
+20588c743195b1d0e3ff3aaba0b8a0e68c23e700ea16410fefad7191c33a623051f669a6d1d9136d7a8c474ac08b75511b4d50862aa836e6e0105e5a72e1c0fb raft-0.18.1.tar.gz
1e0e82e42fb9a65e6135e47ef17494e40f973c9a1af8aab09ff10fdbee83b55183414ec6938205806a9f954bbefaaa5eee776bbd313072ac7ce0105f18a2be03 unistd-include.patch
+b5c6e5a1ae1b6a06005cdbd3d3379e1d0bc6136307578089971f8ac48601958e9d1d31410d26da4cc91206813a56f01ee59fca64cd68e9a37a9921a339b6bf05 disable-bind-address-test-segfaulting.patch
"