aboutsummaryrefslogtreecommitdiffstats
path: root/community/remind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/remind/APKBUILD')
-rw-r--r--community/remind/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/remind/APKBUILD b/community/remind/APKBUILD
index bb7b463e6d7..28291318815 100644
--- a/community/remind/APKBUILD
+++ b/community/remind/APKBUILD
@@ -1,12 +1,13 @@
-# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=remind
-pkgver=03.03.07
+pkgver=04.03.04
pkgrel=0
pkgdesc="Sophisticated calendar and alarm program"
url="https://dianne.skoll.ca/projects/remind/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-only"
+checkdepends="tzdata"
options="!check"
subpackages="$pkgname-doc tkremind::noarch"
source="https://dianne.skoll.ca/projects/remind/download/remind-$pkgver.tar.gz"
@@ -19,19 +20,22 @@ build() {
make
}
+check() {
+ make -j1 test
+}
+
package() {
make DESTDIR="$pkgdir" install
}
tkremind() {
- depends="remind tk"
+ depends="$pkgname=$pkgver-r$pkgrel tk tcl-lib"
- local src="$pkgdir"/usr/bin
- local dest="$subpkgdir"/usr/bin
- mkdir -p "$dest"
- mv "$src"/cm2rem.tcl "$src"/tkremind "$dest"
+ amove usr/bin/tkremind
+ amove usr/share/applications/tkremind.desktop
+ amove usr/share/pixmaps/tkremind.png
}
sha512sums="
-e8604f43ee69ee3159b872dd2cf7469a8c2a5ec3e2b14efc35db3942d28de73a63de5432b2e0419405b4573298bcb96ffa1ac600db54df63b2d4690a824d33fd remind-03.03.07.tar.gz
+9f65e07690d31bb9ab6b242e61265d681cdfac620fa6cd632ad48976f2742cbf1fee13e619ecd332f1c80f5b849a4e6fb9121ac8dfd78ab8631ac6209641cdfa remind-04.03.04.tar.gz
"