aboutsummaryrefslogtreecommitdiffstats
path: root/community/remind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/remind/APKBUILD')
-rw-r--r--community/remind/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/remind/APKBUILD b/community/remind/APKBUILD
index 6d1907ceab5..38405732c8d 100644
--- a/community/remind/APKBUILD
+++ b/community/remind/APKBUILD
@@ -1,12 +1,13 @@
-# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=remind
-pkgver=03.03.08
+pkgver=04.03.06
pkgrel=0
pkgdesc="Sophisticated calendar and alarm program"
url="https://dianne.skoll.ca/projects/remind/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-only"
+checkdepends="tzdata"
options="!check"
subpackages="$pkgname-doc tkremind::noarch"
source="https://dianne.skoll.ca/projects/remind/download/remind-$pkgver.tar.gz"
@@ -19,19 +20,22 @@ build() {
make
}
+check() {
+ make -j1 test
+}
+
package() {
make DESTDIR="$pkgdir" install
}
tkremind() {
- depends="remind tk"
+ depends="$pkgname=$pkgver-r$pkgrel tk tcl-lib"
- local src="$pkgdir"/usr/bin
- local dest="$subpkgdir"/usr/bin
- mkdir -p "$dest"
- mv "$src"/cm2rem.tcl "$src"/tkremind "$dest"
+ amove usr/bin/tkremind
+ amove usr/share/applications/tkremind.desktop
+ amove usr/share/pixmaps/tkremind.png
}
sha512sums="
-fbff9f0caaa3772d71c2b6e4a08c8931095a5a7b15e7bd71e646eb3bdae2bfde3ddc37b09d1563ed9f1eedccec76ecc56c35b540f1d089fec28c3f2b8e962190 remind-03.03.08.tar.gz
+a1edd2dbb7a96bb41aa9bab20053e80846d8aeda27b4d9dbdace360c983754682b4e3838e40d023860a08cb76fbf8929caf36fd388c3a2455914029c3ad8eba8 remind-04.03.06.tar.gz
"