aboutsummaryrefslogtreecommitdiffstats
path: root/community/restic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/restic/APKBUILD')
-rw-r--r--community/restic/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/restic/APKBUILD b/community/restic/APKBUILD
index 5e5fef795a5..32e325b6896 100644
--- a/community/restic/APKBUILD
+++ b/community/restic/APKBUILD
@@ -1,23 +1,23 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=restic
-pkgver=0.12.1
+pkgver=0.16.4
pkgrel=2
pkgdesc="Fast, secure, efficient backup program"
url="https://restic.net/"
-# mips(64): test failures due to fallocate not being supported
-# armhf: https://github.com/restic/restic/issues/3505
-arch="all !mips !mips64 !armhf"
+arch="all"
license="BSD-2-Clause"
makedepends="go"
options="net chmod-clean"
subpackages="$pkgname-doc $pkgname-bash-completion $pkgname-zsh-completion"
source="https://github.com/restic/restic/releases/download/v$pkgver/restic-$pkgver.tar.gz"
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build ./cmd/...
+ go build -v ./cmd/...
}
check() {
@@ -40,5 +40,5 @@ package() {
}
sha512sums="
-a95ad2731889a54a26bd38d7c00285b5fee631d7b44bf553a37ef827747912ac03d5282b7fe5791705c98267cddb6282d82f13c1b6c489d1c09148da4fa526e7 restic-0.12.1.tar.gz
+9f28f90466a30a3c1f32cd1951dddaa22d30ece8b1c18da1a907cc1dd0f98065c25529e855b56fc3d62801b052371d9fe117cd26f17e15276f6a9a309416e914 restic-0.16.4.tar.gz
"