aboutsummaryrefslogtreecommitdiffstats
path: root/community/restic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/restic/APKBUILD')
-rw-r--r--community/restic/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/restic/APKBUILD b/community/restic/APKBUILD
index 00ec4528c2a..32e325b6896 100644
--- a/community/restic/APKBUILD
+++ b/community/restic/APKBUILD
@@ -1,22 +1,23 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=restic
-pkgver=0.12.0
-pkgrel=1
+pkgver=0.16.4
+pkgrel=2
pkgdesc="Fast, secure, efficient backup program"
url="https://restic.net/"
-# mips(64): test failures due to fallocate not being supported
-arch="all !mips !mips64"
+arch="all"
license="BSD-2-Clause"
makedepends="go"
options="net chmod-clean"
subpackages="$pkgname-doc $pkgname-bash-completion $pkgname-zsh-completion"
source="https://github.com/restic/restic/releases/download/v$pkgver/restic-$pkgver.tar.gz"
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build ./cmd/...
+ go build -v ./cmd/...
}
check() {
@@ -38,4 +39,6 @@ package() {
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="2c303bdf61b28939dd02f867a9e5134046b782edafd53cd443641a0811fbcdd3f86af9a4466b258e2d0b7295809ffb78dacf44d1dabd2fd5a25b5bd93e733c9d restic-0.12.0.tar.gz"
+sha512sums="
+9f28f90466a30a3c1f32cd1951dddaa22d30ece8b1c18da1a907cc1dd0f98065c25529e855b56fc3d62801b052371d9fe117cd26f17e15276f6a9a309416e914 restic-0.16.4.tar.gz
+"