aboutsummaryrefslogtreecommitdiffstats
path: root/community/rinutils
diff options
context:
space:
mode:
Diffstat (limited to 'community/rinutils')
-rw-r--r--community/rinutils/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/rinutils/APKBUILD b/community/rinutils/APKBUILD
index 905fd2f17e2..cf39625bf50 100644
--- a/community/rinutils/APKBUILD
+++ b/community/rinutils/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=rinutils
-pkgver=0.8.0
+pkgver=0.10.2
pkgrel=0
pkgdesc="C11 / gnu11 utilities C library"
url="https://www.shlomifish.org/open-source/projects/"
@@ -11,6 +11,7 @@ makedepends="
cmake
cmocka-dev
perl
+ samurai
"
checkdepends="
perl-dev
@@ -28,8 +29,8 @@ source="https://github.com/shlomif/rinutils/releases/download/$pkgver/rinutils-$
options="!check" # Requires unavailable perl modules Test::TrainlingSpace module
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -41,7 +42,9 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="06bbcdb5092762bf2ed92d4082eca17e8dc0e822ce8634f8ec8782fe7eccb4b954c081dbba3f1e2f72e0285607a813f020d4277af77accc43135bde50153359d rinutils-0.8.0.tar.xz"
+sha512sums="
+e2bc6304e84235947aa9aeb09fae0a27c10892ce547d59ab82569e2f03219a783a20c3bf7bd8a471464c2c07fe465eb8f2985e31d1f0e060da7d7bd832a67b67 rinutils-0.10.2.tar.xz
+"