aboutsummaryrefslogtreecommitdiffstats
path: root/community/rlwrap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/rlwrap/APKBUILD')
-rw-r--r--community/rlwrap/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/rlwrap/APKBUILD b/community/rlwrap/APKBUILD
new file mode 100644
index 00000000000..5de196297a9
--- /dev/null
+++ b/community/rlwrap/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=rlwrap
+pkgver=0.46.1
+pkgrel=0
+pkgdesc="readline wrapper"
+url="https://github.com/hanslub42/rlwrap"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="readline-dev ncurses-dev automake autoconf libtool"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hanslub42/rlwrap/archive/$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+558f16cfd7bd0f80e2ba7cf8764248c94f13a497607c491d4148ad5c2b7bbe5c6b72aba4901753792b1377fb402e9e7876636c03b5a6595d5884f93b20505eb2 rlwrap-0.46.1.tar.gz
+"