aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/roundcubemail/APKBUILD')
-rw-r--r--community/roundcubemail/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 540f486abdd..1be6db4f166 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -62,8 +62,6 @@ prepare() {
cd "$builddir"
default_prepare
- # fix permissions
- find . -type f -print | xargs chmod a-x
# remove .htaccess
find . -name \.htaccess -print | xargs rm -f
@@ -73,6 +71,20 @@ prepare() {
# Useless 'cause there's no FOSS PDO driver.
rm -R SQL/oracle*
+
+ cd bin
+
+ # Remove development scripts.
+ rm -f cssshrink.* dumpschema.* install-jsdeps.* installto.* \
+ jsshrink.* makedoc.*
+
+ # These are all PHP files, not shell scripts!
+ local file; for file in *.sh; do
+ mv $file ${file%.sh}.php
+ done
+
+ # Fix shebang.
+ sed -i "s|/usr/bin/env php|/usr/bin/env $_php|" *.php
}
package() {