aboutsummaryrefslogtreecommitdiffstats
path: root/community/rpm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/rpm/APKBUILD')
-rw-r--r--community/rpm/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/rpm/APKBUILD b/community/rpm/APKBUILD
index d57b89b25d0..f1c020e0702 100644
--- a/community/rpm/APKBUILD
+++ b/community/rpm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=rpm
pkgver=4.15.1
-pkgrel=1
+pkgrel=2
pkgdesc="Redhat Package Management utilities (RPM)"
url="https://www.rpm.org/"
arch="all"
@@ -25,16 +25,20 @@ build() {
_EXT_CPPFLAGS="-I/usr/include/nspr -I/usr/include/nss" \
CFLAGS="$CFLAGS $_EXT_CPPFLAGS" CPPFLAGS="$CPPFLAGS $_EXT_CPPFLAGS" \
LIBS="$LIBS -lintl" \
+ PYTHON=python3 \
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--with-external-db \
- --with-cap --with-acl \
- --without-lua --enable-python \
- --enable-zstd=yes --disable-inhibit-plugin \
- --with-crypto=nss PYTHON=python3
+ --with-cap \
+ --with-acl \
+ --without-lua \
+ --enable-python \
+ --enable-zstd=yes \
+ --with-crypto=nss \
+ --disable-plugins
make
}