aboutsummaryrefslogtreecommitdiffstats
path: root/community/rspamd/08-errors.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/rspamd/08-errors.patch')
-rw-r--r--community/rspamd/08-errors.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/community/rspamd/08-errors.patch b/community/rspamd/08-errors.patch
deleted file mode 100644
index cbfd21d586b..00000000000
--- a/community/rspamd/08-errors.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Nurp a/CMakeLists.txt b.allerrors/CMakeLists.txt
---- a/CMakeLists.txt 2020-09-30 20:27:23.000000000 +0100
-+++ b.allerrors/CMakeLists.txt 2020-12-27 18:35:06.703013307 +0000
-@@ -23,6 +23,8 @@ SET(RSPAMD_VERSION "${RSPAMD_VER
-
- PROJECT(rspamd VERSION "${RSPAMD_VERSION}" LANGUAGES C CXX ASM)
-
-+CMAKE_POLICY(SET CMP0075 NEW)
-+
- # This is supported merely with cmake 3.1
- SET(CMAKE_C_STANDARD 11)
- SET(CMAKE_C_STANDARD_REQUIRED ON)
-diff -Nurp a/contrib/mumhash/mum.h b.allerrors/contrib/mumhash/mum.h
---- a/contrib/mumhash/mum.h 2020-09-30 20:27:23.000000000 +0100
-+++ b.allerrors/contrib/mumhash/mum.h 2020-12-27 18:05:30.916331886 +0000
-@@ -115,7 +115,7 @@ _mum (uint64_t v, uint64_t p) {
- multiplication. If we use a generic code we actually call a
- function doing 128x128->128 bit multiplication. The function is
- very slow. */
-- lo = v * p, hi;
-+ lo = v * p;
- __asm__ ("umulh %0, %1, %2" : "=r" (hi) : "r" (v), "r" (p));
- #else
- __uint128_t r = (__uint128_t) v * (__uint128_t) p;