aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-escape_utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-escape_utils/APKBUILD')
-rw-r--r--community/ruby-escape_utils/APKBUILD36
1 files changed, 25 insertions, 11 deletions
diff --git a/community/ruby-escape_utils/APKBUILD b/community/ruby-escape_utils/APKBUILD
index 81ca3240b4f..5f6dabd1e5b 100644
--- a/community/ruby-escape_utils/APKBUILD
+++ b/community/ruby-escape_utils/APKBUILD
@@ -3,22 +3,35 @@
# TODO: Fix to not compile .so lib twice (in build and test).
pkgname=ruby-escape_utils
_gemname=${pkgname#ruby-}
-pkgver=1.2.1
-pkgrel=4
+pkgver=1.3.0
+pkgrel=2
pkgdesc="Faster string escaping routines for your Ruby apps"
url="https://github.com/brianmario/escape_utils"
arch="all"
license="MIT"
-checkdepends="ruby ruby-bundler ruby-minitest ruby-rake-compiler"
makedepends="ruby-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/brianmario/escape_utils/archive/$pkgver.tar.gz
+checkdepends="
+ ruby
+ ruby-activesupport
+ ruby-minitest
+ ruby-rake-compiler
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/brianmario/escape_utils/archive/v$pkgver.tar.gz
gemspec.patch
- fix-tests-for-ruby-2.5.patch"
+ test-without-actionview.patch
+ "
builddir="$srcdir/$_gemname-$pkgver"
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
+
+ sed -i '/require .bundler/d' Rakefile
+ # Requires gem activeview which we don't have in aports yet.
+ rm -rf test/javascript
+}
+
+build() {
gem build $_gemname.gemspec
gem install --local \
--install-dir dist \
@@ -29,7 +42,6 @@ build() {
}
check() {
- cd "$builddir"
rake test
}
@@ -44,6 +56,8 @@ package() {
rm -r "$gemdir"/gems/$_gemname-$pkgver/ext
}
-sha512sums="c2af40a2a3c0cc083a55771e2ed813992391c833b6d64cb9255ec5741c2da6980ddf34331256b73f18617cf8df6b745e81bdd6c1632d63936ccd3a655758b083 ruby-escape_utils-1.2.1.tar.gz
-8cb3c26b46304899b2d200208c18650ab28da81ea42d8479a89b06802d252757df537c997fe5f640122a4521016f0676c267c691bc6be33ce066fe4be0c504d5 gemspec.patch
-06de5f7afcc3b7461d9e915d62ae0405d2161c37759c6868c9b550998995935b90e2865d30b1c9c9a0a5a474d96c5f94762114cda7b2c0b825717c8066115b62 fix-tests-for-ruby-2.5.patch"
+sha512sums="
+6d492192ffdf1309366ae545d2c282f7d10d6618a4a0a4b5148a4c2a62d8f9dbd5e821dc04e0a12bec5ad4e2bb11fab60b26592c35f9d1d2f046163db2c27957 ruby-escape_utils-1.3.0.tar.gz
+fd5ef02273b3aa93d18a3d1c86f6d9c47163f9adf5ca236eef3fe556c2ba84d5ada15ae2a37f121a6e273aa39bbdcdb47bcfa5d5bcac6dd80a84e0b279c91825 gemspec.patch
+1add3df7b4f8c9acb56a9c76407ef1d25a127bf24ed167d65a0c167068d0bf7bdec699c413f03963e6b617404fa10c5ec6e82a7c6d784c5e5a8b1bc16fd54252 test-without-actionview.patch
+"