aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-mathematical/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-mathematical/APKBUILD')
-rw-r--r--community/ruby-mathematical/APKBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/community/ruby-mathematical/APKBUILD b/community/ruby-mathematical/APKBUILD
index c1f39c540a9..998549dc5fd 100644
--- a/community/ruby-mathematical/APKBUILD
+++ b/community/ruby-mathematical/APKBUILD
@@ -12,7 +12,6 @@ depends="ruby ruby-enum"
makedepends="cmake lasem-dev mtex2mml-dev ruby-dev"
checkdepends="mtex2mml-fixtures ruby-io-console ruby-irb ruby-json
ruby-minitest ruby-nokogiri ruby-rake"
-options="!check" # TODO: tests fails with ruby 2.7.
source="$pkgname-$pkgver.tar.gz::https://github.com/gjtorikian/$_gemname/archive/v$pkgver.tar.gz
use-system-mtex2mml-fixtures.patch"
builddir="$srcdir/$_gemname-$pkgver"
@@ -21,7 +20,7 @@ prepare() {
default_prepare
# Don't load bundler, it messes with GEM_PATH.
- sed -i "/^require\s*[\"']bundler\/setup/d" test/test_helper.rb
+ sed -i "/^require\s*[\"']bundler/d" Rakefile test/test_helper.rb
# Some tests in this file are unstable (randomly fails).
# https://github.com/gjtorikian/mathematical/issues/73