aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-mustache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-mustache/APKBUILD')
-rw-r--r--community/ruby-mustache/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/ruby-mustache/APKBUILD b/community/ruby-mustache/APKBUILD
index 2dd64e35725..dfe955cf7ef 100644
--- a/community/ruby-mustache/APKBUILD
+++ b/community/ruby-mustache/APKBUILD
@@ -3,16 +3,17 @@
pkgname=ruby-mustache
_gemname=mustache
pkgver=1.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Logic-less Ruby templates"
url="https://mustache.github.io/"
arch="noarch"
license="MIT"
depends="ruby"
-options="!check" # TODO: check seems to fail on all arches except x86_64
checkdepends="ruby-minitest ruby-rake ruby-rdoc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mustache/mustache/archive/v$pkgver.tar.gz
- skip-simplecov.patch"
+ fix-test-race-condition.patch
+ skip-simplecov.patch
+ "
builddir="$srcdir/$_gemname-$pkgver"
build() {
@@ -42,4 +43,5 @@ package() {
}
sha512sums="3bfe85698ffc95828cb2c6d7ee77049a7dab3a60313289cb0b19e9210d17e4de043df913784c5322a0d9d2073ee6be66f973df9b290e939a0eab153727c31fab ruby-mustache-1.1.1.tar.gz
+bb122077fa486acd9b737dcf961baeae53b766a48bc635ac48b11e675923885c8110b0095a2600f1655adb034938b04c979c1f5a5d7064d040c207f47eb4d2cc fix-test-race-condition.patch
1d457e4f059aabb76f2b84fbebb513a3872715b83508528f06c8de5ea98262a4e266c154fa8cf3f5cae0a9fff6e0b82e0c2278f7979ac27a60b202b825b41e5e skip-simplecov.patch"