aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rspec-expectations/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rspec-expectations/APKBUILD')
-rw-r--r--community/ruby-rspec-expectations/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/ruby-rspec-expectations/APKBUILD b/community/ruby-rspec-expectations/APKBUILD
index 25142e25dd6..91aa290fd4d 100644
--- a/community/ruby-rspec-expectations/APKBUILD
+++ b/community/ruby-rspec-expectations/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-rspec-expectations
_gemname=${pkgname#ruby-}
-pkgver=3.8.4
-pkgrel=1
+pkgver=3.13.0
+pkgrel=0
pkgdesc="Provides a readable API to express expected outcomes of a code example in RSpec"
url="https://relishapp.com/rspec/rspec-expectations/"
arch="noarch"
@@ -15,14 +15,12 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pk
builddir="$srcdir/$_gemname-$pkgver"
build() {
- cd "$builddir"
gem build $_gemname.gemspec
}
package() {
local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
- cd "$builddir"
gem install --local \
--install-dir "$gemdir" \
--ignore-dependencies \
@@ -36,5 +34,7 @@ package() {
"$gemdir"/doc
}
-sha512sums="0ecb16f11ccf19c02c40ce587f33846fb2241f1663dd87f012b9b782338c213362dac624c434dee6e00ad2cc7ec4a1cd0af7f2edf1a8e9ebb0a0dfb31cd244d8 ruby-rspec-expectations-3.8.4.tar.gz
-1d477004521852e23d01b197187dbb434a2c7fd179e506c82a12e17f5d52470fe2a113112e7052b9479077eafa6759beb07c03301de1f8ea7f5c4643c92d8346 gemspec.patch"
+sha512sums="
+9e1e502d12704fd7573a57b7f01cf4ffe97e2eefe83dc3144842f460165304dc234a1b1946147f2cbcae105d755c8b42b25aec815f9af0c67844baf858c0a6c7 ruby-rspec-expectations-3.13.0.tar.gz
+1d477004521852e23d01b197187dbb434a2c7fd179e506c82a12e17f5d52470fe2a113112e7052b9479077eafa6759beb07c03301de1f8ea7f5c4643c92d8346 gemspec.patch
+"