aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-timecop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-timecop/APKBUILD')
-rw-r--r--community/ruby-timecop/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/ruby-timecop/APKBUILD b/community/ruby-timecop/APKBUILD
index 9558dcaa8f1..8142977cd05 100644
--- a/community/ruby-timecop/APKBUILD
+++ b/community/ruby-timecop/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-timecop
_gemname=${pkgname#ruby-}
-pkgver=0.9.4
-pkgrel=0
+pkgver=0.9.8
+pkgrel=1
pkgdesc="A gem providing 'time travel' and 'time freezing' capabilities"
url="https://github.com/travisjeffery/timecop"
arch="noarch"
@@ -14,14 +14,12 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/travisjeffery/$_gemname/arch
builddir="$srcdir/$_gemname-$pkgver"
build() {
- cd "$builddir"
gem build $_gemname.gemspec
}
package() {
local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
- cd "$builddir"
gem install --local \
--install-dir "$gemdir" \
--ignore-dependencies \
@@ -33,7 +31,9 @@ package() {
cd "$gemdir"
rm -r cache/ build_info/ doc/
cd gems/$_gemname-$pkgver
- rm -r test/ Rakefile README* LICENSE
+ rm -r Rakefile README* LICENSE
}
-sha512sums="b50f01b69b6f253ea40d445301586219ca9032af0f9a4b0ca990eabfb4b81051dd96acc2d75a8ccb5333fa2d4842c0eee28d1c28b335d9a36826c6d70161830b ruby-timecop-0.9.4.tar.gz"
+sha512sums="
+cbf74e8d4e459f17cb841fee14353feccfa26e401d999521abb5653639a3d6b8e0dbd73d4317cb18b185d33d23e20e7603992cd6e2752ac74cbf0c0c927263b3 ruby-timecop-0.9.8.tar.gz
+"