aboutsummaryrefslogtreecommitdiffstats
path: root/community/runc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/runc/APKBUILD')
-rw-r--r--community/runc/APKBUILD39
1 files changed, 24 insertions, 15 deletions
diff --git a/community/runc/APKBUILD b/community/runc/APKBUILD
index cebde5de0e2..635b52e9ac9 100644
--- a/community/runc/APKBUILD
+++ b/community/runc/APKBUILD
@@ -4,18 +4,29 @@
pkgname=runc
pkgdesc="CLI tool for spawning and running containers according to the OCI specification"
url="https://www.opencontainers.org"
-_commit=a916309fff0f838eb94e928713dbc3c0d0ac7aa4
-pkgver=1.1.2
-pkgrel=0
+_commit=51d5e94601ceffbbd85688df1c928ecccbfa4685
+pkgver=1.1.12
+pkgrel=2
arch="all"
license="Apache-2.0"
makedepends="bash go go-md2man libseccomp-dev libtool"
subpackages="$pkgname-doc"
-source="https://github.com/opencontainers/runc/archive/v$pkgver/runc-$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/opencontainers/runc"
+source="https://github.com/opencontainers/runc/archive/v$pkgver/runc-$pkgver.tar.gz
+ "
options="!check"
+provides="oci-runtime"
+provider_priority=90
+
# secfixes:
+# 1.1.12-r0:
+# - CVE-2024-21626
+# 1.1.4-r0:
+# - CVE-2023-25809
+# - CVE-2023-27561
+# - CVE-2023-28642
+# 1.1.4-r7:
+# - CVE-2023-27561
# 1.1.2-r0:
# - CVE-2022-29162
# 1.0.3-r0:
@@ -29,22 +40,20 @@ options="!check"
# 1.0.0_rc7-r0:
# - CVE-2019-5736
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- cd "$srcdir"
- export GOPATH="$PWD"
- mkdir -p "$(dirname "$builddir")"
- ln -s "$PWD/$pkgname-$pkgver" "$builddir"
- cd "$builddir"
- make COMMIT="$_commit" EXTRA_LDFLAGS="-w -s"
+ make COMMIT="$_commit"
make man
}
package() {
- install -Dsm755 "$builddir"/runc "$pkgdir"/usr/bin/runc
- install -d "$pkgdir"/usr/share/man/man8/
- install -Dm644 "$builddir"/man/man8/* "$pkgdir"/usr/share/man/man8/
+ install -Dsm755 runc "$pkgdir"/usr/bin/runc
+ install -Dm644 "$builddir"/man/man8/* -t "$pkgdir"/usr/share/man/man8/
}
sha512sums="
-61d8cc82f49e3bc1cf4cc4ae18a9d9c8f4ae93e8380ce6fa9034b154bd1b915339ee65babdf7518021d015a3c31545fcbad5bbf0c4579c7eb50988877121f049 runc-1.1.2.tar.gz
+92e8ac54a77d7ebcc76b5a9cc08d9a064211f12e9d26f064070cc203a5afb11c3af28d8f556f297513f797a2933d50bf10a8f22e307724041d66aa8c5ca1d9d3 runc-1.1.12.tar.gz
"