aboutsummaryrefslogtreecommitdiffstats
path: root/community/rutorrent
diff options
context:
space:
mode:
Diffstat (limited to 'community/rutorrent')
-rw-r--r--community/rutorrent/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/rutorrent/APKBUILD b/community/rutorrent/APKBUILD
index 6729557edd7..9a9636da2d1 100644
--- a/community/rutorrent/APKBUILD
+++ b/community/rutorrent/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Francesco Colis_ta <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=rutorrent
-pkgver=3.7
-pkgrel=2
+_pkgname=ruTorrent
+pkgver=3.8
+pkgrel=0
pkgdesc="Yet another web front-end for rTorrent"
-url="http://code.google.com/p/rutorrent/"
+url="https://github.com/Novik/ruTorrent"
arch="noarch"
license="GPL"
depends="php5 curl"
@@ -14,12 +15,12 @@ makedepends="tar"
pkggroups="rutorrent"
install="$pkgname.pre-install $pkgname.post-install"
subpackages=""
-source="http://dl.bintray.com/novik65/generic/ruTorrent-$pkgver.zip"
-builddir="$srcdir"/ruTorrent-master
+source="$pkgname-$pkgver.tar.gz::https://github.com/Novik/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- chmod -R u+w "$builddir"
+ chmod -R u+w "$builddir"
}
package() {
@@ -33,6 +34,4 @@ package() {
chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
}
-md5sums="8ef91254d5bbf45da3e1d1962b6fe8e7 ruTorrent-3.7.zip"
-sha256sums="c1fb86317231c8e8fa9e1a7dea450ce4687d94caad22d763bc68d90c56d0749f ruTorrent-3.7.zip"
-sha512sums="b8e1173e39f90c21903f3f5cc39377fb7a874bd2023130f4ffba6927ed85583c7934709eea130b1871f217f873c888fc42d53a0f9bb3ee4397f01b3aff850660 ruTorrent-3.7.zip"
+sha512sums="ea3dfa74234a1eafcbc9e71d6c6d953a46fdf8e189237b8df0ec58cf46ac30404f7a15bb783ec7567ab6f28daa3987ee219039dd360e3c48d16aea244263c9b6 rutorrent-3.8.tar.gz"