aboutsummaryrefslogtreecommitdiffstats
path: root/community/s-tui/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/s-tui/APKBUILD')
-rw-r--r--community/s-tui/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/s-tui/APKBUILD b/community/s-tui/APKBUILD
new file mode 100644
index 00000000000..157e6a8e9b7
--- /dev/null
+++ b/community/s-tui/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Kay Thomas <kaythomas@pm.me>
+# Maintainer: Kay Thomas <kaythomas@pm.me>
+pkgname=s-tui
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Terminal-based CPU stress and monitoring utility"
+url="https://github.com/amanusk/s-tui"
+arch="noarch"
+license="GPL-2.0-or-later"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+depends="python3 py3-urwid py3-psutil stress-ng"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/amanusk/s-tui/archive/v$pkgver.tar.gz"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 s_tui/tests/test_util_source.py
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+73412b55175ca2a5e98e410a3c9b5ce9aa1cffc13eb9af26e834d0ea784c06f6a9f81bb1be028b8cf94046ff0a8b20fff5b1191c949d49a72cecf3abd6a1fc38 s-tui-1.1.6.tar.gz
+"