aboutsummaryrefslogtreecommitdiffstats
path: root/community/s-tui/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/s-tui/APKBUILD')
-rw-r--r--community/s-tui/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/s-tui/APKBUILD b/community/s-tui/APKBUILD
index a6a8d1d8b5b..157e6a8e9b7 100644
--- a/community/s-tui/APKBUILD
+++ b/community/s-tui/APKBUILD
@@ -1,28 +1,34 @@
-# Contributor: Kevin Thomas <me@kevinthomas.dev>
-# Maintainer: Kevin Thomas <me@kevinthomas.dev>
+# Contributor: Kay Thomas <kaythomas@pm.me>
+# Maintainer: Kay Thomas <kaythomas@pm.me>
pkgname=s-tui
-pkgver=1.1.3
+pkgver=1.1.6
pkgrel=1
pkgdesc="Terminal-based CPU stress and monitoring utility"
url="https://github.com/amanusk/s-tui"
arch="noarch"
license="GPL-2.0-or-later"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
depends="python3 py3-urwid py3-psutil stress-ng"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/amanusk/s-tui/archive/v$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$builddir" python3 s_tui/tests/test_util_source.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 s_tui/tests/test_util_source.py
}
package() {
- python3 setup.py install --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-80a746187d7d4e4581b6a7c68c3939772eed95ae16530ca38692c9fcfdb98068e60fbe401cf741e1896d8a303a240b231c27a7bf5471c24357fe06df6fdfb153 s-tui-1.1.3.tar.gz
+73412b55175ca2a5e98e410a3c9b5ce9aa1cffc13eb9af26e834d0ea784c06f6a9f81bb1be028b8cf94046ff0a8b20fff5b1191c949d49a72cecf3abd6a1fc38 s-tui-1.1.6.tar.gz
"