aboutsummaryrefslogtreecommitdiffstats
path: root/community/sbcl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sbcl/APKBUILD')
-rw-r--r--community/sbcl/APKBUILD43
1 files changed, 31 insertions, 12 deletions
diff --git a/community/sbcl/APKBUILD b/community/sbcl/APKBUILD
index 2c07708ad70..dec698d5996 100644
--- a/community/sbcl/APKBUILD
+++ b/community/sbcl/APKBUILD
@@ -3,27 +3,46 @@
# Contributor: Will Sinatra <wpsinatra@gmail.com>
# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=sbcl
-pkgver=2.1.5
+pkgver=2.4.1
pkgrel=0
pkgdesc="Steel Bank Common Lisp"
url="http://www.sbcl.org/"
-arch="x86 x86_64 armv7 aarch64"
+# riscv64: No rule to make target 'genesis/Makefile.features'. Stop.
+# ppc64le: doesn't build
+arch="all !ppc64le !s390x !riscv64"
license="custom"
options="!check"
checkdepends="ed"
-makedepends="ecl ecl-dev gmp-dev gc gc-dev libffi-dev linux-headers zlib-dev"
+makedepends="
+ ecl-dev>=21.2.1-r2
+ emacs-nox
+ gc-dev
+ gmp-dev
+ libffi-dev
+ linux-headers
+ mpfr-dev
+ zstd-dev
+ "
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.bz2::https://prdownloads.sourceforge.net/sbcl/sbcl-$pkgver-source.tar.bz2
- Fix-ARM-build-using-ECL-host.patch
- march-armv5-removed.patch"
+ ppc-musl.patch
+ march-armv5-removed.patch
+ "
build() {
- all_arch_conf='--with-sb-test --with-sb-unicode --with-sb-core-compression'
+ #All systems can build with these features enabled
+ all_arch_conf='--with-sb-test --with-sb-unicode --with-sb-core-compression --with-sb-linkable-runtime --with-sb-dynamic-core'
+ #Please add additional package support by arch
+ #armv7 is incapable of supporting sb:thread
+ #x86 can be built with sb:thread, but as of 2.2.5 it causes a memory corruption
case "$CARCH" in
armv7) conf="$all_arch_conf" ;;
- aarch64) ;;
- *) conf="$all_arch_conf --with-sb-thread" ;;
+ x86) conf="$all_arch_conf --without-sb-thread" ;;
+ x86_64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ aarch64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ riscv64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ ppc64le) conf="$all_arch_conf" ;;
esac
GNUMAKE=make ./make.sh ecl --prefix=/usr $conf
@@ -38,12 +57,12 @@ package() {
install -Dm644 COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
- rmdir "$pkgdir"/usr/share/doc/sbcl/html \
+ rmdir "$pkgdir"/usr/share/doc/$pkgname/html \
"$pkgdir"/usr/share/info 2>/dev/null || true
}
sha512sums="
-5e208b3a1b3ff1a589c9ae0398e40086d979342c11fa7bb251797d0266618801b525dddb6998cebae3fc2a88547f7a71bdc43c5418f5edc2cf9bf699ed725334 sbcl-2.1.5.tar.bz2
-6f49d1f1c6bd4e8d839e6b4ab3bb74cbdcce85ee83a0f1c5efab04d97b613a624f8874dadd7f6d981940ff28c468f00b74a56ff2afc53f41884d753ac7a5028f Fix-ARM-build-using-ECL-host.patch
-1d84ae70a6063682cecd395bc76009e87c4e0a0b4c0ec0c8a6c8187e9692d1aaf4035a7fb54e9e363ef92fca795a9d70703b1d3b0be0794a95a37c8635eeede3 march-armv5-removed.patch
+ae78f4d64063c05f82748239f661fb88792652496fced0a7bedcd00fda6b17cf9e01b866a5a11ca953746bc8b208116b73a93288ad08c9ffe578cc3266870780 sbcl-2.4.1.tar.bz2
+549cc9936ddbd4c19067a455dfad151bd0ce59200b2dce761de67e259e621e4174beefaa5a322886bcd731d2470d229a3e1b75a55a194c54e2feb7c0bcdffb37 ppc-musl.patch
+b8b9b8d8e489bfa18d0c59de54420e5a930a9c0e4cb9ffe1fe9c69d6a10b67880601b66ca2fab0fe77733f722b6709bf8e1cd32a257398a6e28d61b50080e26e march-armv5-removed.patch
"