aboutsummaryrefslogtreecommitdiffstats
path: root/community/sbcl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sbcl/APKBUILD')
-rw-r--r--community/sbcl/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/sbcl/APKBUILD b/community/sbcl/APKBUILD
new file mode 100644
index 00000000000..aa57446fd29
--- /dev/null
+++ b/community/sbcl/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Eric Timmons <etimmons@alum.mit.edu>
+# Contributor: Will Sinatra <wpsinatra@gmail.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+pkgname=sbcl
+pkgver=2.4.3
+pkgrel=0
+pkgdesc="Steel Bank Common Lisp"
+url="http://www.sbcl.org/"
+# riscv64: No rule to make target 'genesis/Makefile.features'. Stop.
+# ppc64le: doesn't build
+arch="all !ppc64le !s390x !riscv64 !x86"
+license="custom"
+options="!check"
+checkdepends="ed"
+makedepends="
+ ecl-dev>=21.2.1-r2
+ emacs-nox
+ gc-dev
+ gmp-dev
+ libffi-dev
+ linux-headers
+ mpfr-dev
+ zstd-dev
+ "
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.bz2::https://prdownloads.sourceforge.net/sbcl/sbcl-$pkgver-source.tar.bz2
+ ppc-musl.patch
+ march-armv5-removed.patch
+ "
+
+build() {
+ #All systems can build with these features enabled
+ all_arch_conf='--with-sb-test --with-sb-unicode --with-sb-core-compression --with-sb-linkable-runtime --with-sb-dynamic-core'
+
+ #Please add additional package support by arch
+ #armv7 is incapable of supporting sb:thread
+ #x86 can be built with sb:thread, but as of 2.2.5 it causes a memory corruption
+ case "$CARCH" in
+ armv7) conf="$all_arch_conf" ;;
+ x86) conf="$all_arch_conf --without-sb-thread" ;;
+ x86_64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ aarch64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ riscv64) conf="$all_arch_conf --fancy --with-sb-thread" ;;
+ ppc64le) conf="$all_arch_conf" ;;
+ esac
+
+ GNUMAKE=make ./make.sh ecl --prefix=/usr $conf
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir/usr" \
+ LIB_DIR="/usr/lib" \
+ DOC_DIR="$pkgdir/usr/share/doc/$pkgname" \
+ sh install.sh
+
+ install -Dm644 COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+
+ rmdir "$pkgdir"/usr/share/doc/$pkgname/html \
+ "$pkgdir"/usr/share/info 2>/dev/null || true
+}
+
+sha512sums="
+ac61e02af16b81cb25a806b44272956dd72875ae884a04b075c983881be70b618908bad7ebddb763358401f7207c05adde932e4a845e5b8cffccc0c7b76e7557 sbcl-2.4.3.tar.bz2
+549cc9936ddbd4c19067a455dfad151bd0ce59200b2dce761de67e259e621e4174beefaa5a322886bcd731d2470d229a3e1b75a55a194c54e2feb7c0bcdffb37 ppc-musl.patch
+b8b9b8d8e489bfa18d0c59de54420e5a930a9c0e4cb9ffe1fe9c69d6a10b67880601b66ca2fab0fe77733f722b6709bf8e1cd32a257398a6e28d61b50080e26e march-armv5-removed.patch
+"