aboutsummaryrefslogtreecommitdiffstats
path: root/community/sddm-kcm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sddm-kcm/APKBUILD')
-rw-r--r--community/sddm-kcm/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/sddm-kcm/APKBUILD b/community/sddm-kcm/APKBUILD
index b103b9babe5..133537cdba5 100644
--- a/community/sddm-kcm/APKBUILD
+++ b/community/sddm-kcm/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=sddm-kcm
-pkgver=5.22.3
+pkgver=6.0.4
pkgrel=0
pkgdesc="Config module for SDDM"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-only"
depends="
@@ -26,9 +28,10 @@ makedepends="
knewstuff-dev
kxmlgui-dev
libxcursor-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+
+ samurai
xcb-util-image-dev
"
@@ -36,13 +39,15 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/sddm-kcm-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/sddm-kcm.git"
+source="https://download.kde.org/stable/plasma/$pkgver/sddm-kcm-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -52,5 +57,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-0b09da15bda6f15bc3aabbc99b6e00a81db2f3d2e4ee567360ea8a8b2100aa79252eed25c0bdc9109754c2959dfabd19bd833a8d7df5416379f9518e283e82c0 sddm-kcm-5.22.3.tar.xz
+41f4d76f214be149d570ec152f0d155566d96831807d498012b2672c203d998bcaa5e2b74e2d45e8bf41d0451fa01fcc6854e8b8717af7b700ae9fc2222c111b sddm-kcm-6.0.4.tar.xz
"