aboutsummaryrefslogtreecommitdiffstats
path: root/community/sdl12-compat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sdl12-compat/APKBUILD')
-rw-r--r--community/sdl12-compat/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/community/sdl12-compat/APKBUILD b/community/sdl12-compat/APKBUILD
index cb00fa5a7cb..4fce5e6c714 100644
--- a/community/sdl12-compat/APKBUILD
+++ b/community/sdl12-compat/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
pkgname=sdl12-compat
# Have the same version as the last upstream release
-pkgver=0.0.1_git20210715
-_commit=7677b7ae855eb4eaf67d47db80bf7b30b90a7558
-pkgrel=0
+pkgver=1.2.64
+pkgrel=3
pkgdesc="SDL-1.2 compat layer that uses SDL-2.0"
-options="!check" # https://github.com/libsdl-org/sdl12-compat/issues/90
url="https://github.com/libsdl-org/sdl12-compat"
arch="all"
license="BSD-3-Clause"
depends="sdl2"
-makedepends="cmake sdl2-dev"
-subpackages="$pkgname-dev"
-source="$pkgname-$_commit.tar.gz::https://github.com/libsdl-org/sdl12-compat/archive/$_commit.tar.gz"
-builddir="$srcdir/$pkgname-$_commit"
+makedepends="cmake samurai sdl2-dev"
+checkdepends="glu-dev mesa-dev"
+subpackages="$pkgname-static $pkgname-dbg $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libsdl-org/sdl12-compat/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-release-$pkgver"
+options="!check" # these are manual tests, not actual
# Otherwise the package will fail installation if sdl is already present
# NOTE(Leo): remove this before the release of 3.15
@@ -22,14 +22,14 @@ replaces="sdl"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ local crossopts="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ CFLAGS="$CFLAGS -O2 -DNDEBUG -flto=auto -I/usr/include/directfb" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DSDL12TESTS=OFF \
- -DCMAKE_C_FLAGS="$CFLAGS -I/usr/include/directfb" \
- $CMAKE_CROSSOPTS .
+ -DSDL12TESTS="$(want_check && echo ON || echo OFF)" \
+ $crossopts
cmake --build build
}
@@ -50,5 +50,5 @@ dev() {
}
sha512sums="
-4d41213114d522aed395ba340f2daea20fb4f76bc8a274e0aaaa6f2ebfaa7b4eae4f20dff5184b4029089f9cc0eaaefab7c352b21cf98987f0fea7425c86870f sdl12-compat-7677b7ae855eb4eaf67d47db80bf7b30b90a7558.tar.gz
+cd551666d2e6a2de273ee29b9a68a5472933a5f5a6340616510051e78f0a96af68a2f13f4473431d6b58ad89a379d672b3a3e82bc86ded01943b6bc3ca7947d2 sdl12-compat-1.2.64.tar.gz
"