aboutsummaryrefslogtreecommitdiffstats
path: root/community/sdl2
diff options
context:
space:
mode:
Diffstat (limited to 'community/sdl2')
-rw-r--r--community/sdl2/0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch46
-rw-r--r--community/sdl2/APKBUILD10
2 files changed, 4 insertions, 52 deletions
diff --git a/community/sdl2/0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch b/community/sdl2/0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch
deleted file mode 100644
index 2fbad97402f..00000000000
--- a/community/sdl2/0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 7c6d466d98910a2896680351cc5cea1b7fb37ab9 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 24 Mar 2020 13:33:40 +0100
-Subject: [PATCH] src/video/directfb/SDL_DirectFB_render.c: fix build
-
-Build with directfb is broken due to a spurious '}' and a missing 'E'
-since version 2.0.12 and https://hg.libsdl.org/SDL/rev/2d5b5a5ccbfb:
-
-/home/buildroot/autobuild/run/instance-2/output-1/build/sdl2-2.0.12/src/video/directfb/SDL_DirectFB_render.c: In function 'SetBlendMode':
-/home/buildroot/autobuild/run/instance-2/output-1/build/sdl2-2.0.12/src/video/directfb/SDL_DirectFB_render.c:202:9: error: case label not within a switch statement
- 202 | case SDL_BLENDMODE_MUL:
- | ^~~~
-
-/home/buildroot/autobuild/run/instance-2/output-1/build/sdl2-2.0.12/src/video/directfb/SDL_DirectFB_render.c:205:67: error: 'DSBF_DSTCOLOR' undeclared (first use in this function); did you mean 'DSBF_DESTCOLOR'?
- 205 | SDL_DFB_CHECK(destsurf->SetSrcBlendFunction(destsurf, DSBF_DSTCOLOR));
- | ^~~~~~~~~~~~~
-
-Fixes:
- - http://autobuild.buildroot.org/results/83ccefee68c2800c0544e6f40fa8bc8ee6b67b77
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Retrieved from: https://hg.libsdl.org/SDL/rev/769f80095217]
----
- src/video/directfb/SDL_DirectFB_render.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/video/directfb/SDL_DirectFB_render.c b/src/video/directfb/SDL_DirectFB_render.c
-index 618009850..cc31fb8f4 100644
---- a/src/video/directfb/SDL_DirectFB_render.c
-+++ b/src/video/directfb/SDL_DirectFB_render.c
-@@ -198,11 +198,10 @@ SetBlendMode(DirectFB_RenderData * data, int blendMode,
- SDL_DFB_CHECK(destsurf->SetDstBlendFunction(destsurf, DSBF_SRCCOLOR));
-
- break;
-- }
- case SDL_BLENDMODE_MUL:
- data->blitFlags = DSBLIT_BLEND_ALPHACHANNEL;
- data->drawFlags = DSDRAW_BLEND;
-- SDL_DFB_CHECK(destsurf->SetSrcBlendFunction(destsurf, DSBF_DSTCOLOR));
-+ SDL_DFB_CHECK(destsurf->SetSrcBlendFunction(destsurf, DSBF_DESTCOLOR));
- SDL_DFB_CHECK(destsurf->SetDstBlendFunction(destsurf, DSBF_INVSRCALPHA));
-
- break;
---
-2.25.1
-
diff --git a/community/sdl2/APKBUILD b/community/sdl2/APKBUILD
index 35ed57c0b06..bed2bea2eb9 100644
--- a/community/sdl2/APKBUILD
+++ b/community/sdl2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: August Klein <amatcoder@gmail.com>
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=sdl2
-pkgver=2.0.12
-pkgrel=5
+pkgver=2.0.14
+pkgrel=0
pkgdesc="development library designed to provide low level access to audio, keyboard, mouse, joystick and graphics"
url="https://www.libsdl.org"
arch="all"
@@ -31,7 +31,6 @@ subpackages="$pkgname-dev"
source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz
directfb-cflags.patch
khronos.patch
- 0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch
"
options="!check" # No good way to run the available tests
builddir="$srcdir/SDL2-$pkgver"
@@ -83,7 +82,6 @@ package() {
make -C build DESTDIR="$pkgdir" install
}
-sha512sums="3f1f04af0f3d9dda9c84a2e9274ae8d83ea0da3fc367970a820036cc4dc1dbf990cfc37e4975ae05f0b45a4ffa739c6c19e470c00bf3f2bce9b8b63717b8b317 SDL2-2.0.12.tar.gz
+sha512sums="ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee SDL2-2.0.14.tar.gz
8efdd02e0e71908b913f4c05b1f02aa94315c2bbffff87d1a46db94723dd7f0ea177e1e00de6c212ad31a00a22aa0fd87f63c3865c4dff2dc98f302046084caf directfb-cflags.patch
-76c93659a122def05f341ba30507b546b201c84823236ca731ac801f092e769574e8f051770a76050a77ac846ed851abab604e0a6d578b382f4792ab47aa60ed khronos.patch
-8de7a7ea80eda5797adf29aa8123511f41dd6980e93203dfd2b080d915fa3b548e2712c68ff76ff09ef4b9cdbdc941cb728d01dc90c962b6bf6b96374de4aa8f 0001-src-video-directfb-SDL_DirectFB_render.c-fix-build.patch"
+76c93659a122def05f341ba30507b546b201c84823236ca731ac801f092e769574e8f051770a76050a77ac846ed851abab604e0a6d578b382f4792ab47aa60ed khronos.patch"