aboutsummaryrefslogtreecommitdiffstats
path: root/community/shards
diff options
context:
space:
mode:
Diffstat (limited to 'community/shards')
-rw-r--r--community/shards/APKBUILD14
-rw-r--r--community/shards/makefile-install.patch52
-rw-r--r--community/shards/use-git-bare-instead-of-mirror.patch18
3 files changed, 5 insertions, 79 deletions
diff --git a/community/shards/APKBUILD b/community/shards/APKBUILD
index 671905762d5..050545627e0 100644
--- a/community/shards/APKBUILD
+++ b/community/shards/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=shards
-pkgver=0.7.2
+pkgver=0.8.0
pkgrel=0
-_minitestver=0.3.6
+_minitestver=0.4.0
pkgdesc="Dependency manager for the Crystal language"
url="https://github.com/crystal-lang/shards"
arch="x86_64 aarch64" # limited by crystal aport
@@ -13,8 +13,6 @@ makedepends="yaml-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archive/v$pkgver.tar.gz
minitest.cr-$_minitestver.tar.gz::https://github.com/ysbaddaden/minitest.cr/archive/v$_minitestver.tar.gz
- use-git-bare-instead-of-mirror.patch
- makefile-install.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -30,7 +28,7 @@ prepare() {
build() {
cd "$builddir"
- make release CRFLAGS=""
+ make
}
check() {
@@ -44,7 +42,5 @@ package() {
make install DESTDIR="$pkgdir" PREFIX=/usr
}
-sha512sums="a99648ae292095278578e47971b556a0da90743db62689a76aae9eab986ad2185ad7adc13c4340f12fce835c5383d8aac93e35258d01fa658e521314eafaf942 shards-0.7.2.tar.gz
-4f802475c6b1be0d1c8844fed1aeba09b8b2b893f413e25115c1687d35348357e9c0076169e38721bedc3cb31ac2463a7c1b243841554f3eca470608a62438a5 minitest.cr-0.3.6.tar.gz
-ab640ab81273042b303abcd23b459f45dfdb8a725bff41043118750d03e6ba0c6bb86a5507f90bb74bf83cb14288dd35ece83b12c63b300f01bf6110e67099cc use-git-bare-instead-of-mirror.patch
-6d5ff4cd2cdf41a4805f17459c614ddc6fbc98df49304067c927e27aaa6c43460409789c7871cfbead27a6d13d3d9b92b80b2aec9a76eefb9b11cf9feb17045b makefile-install.patch"
+sha512sums="c366dec216676975cadfd8210a89c407ddc6335859b323736da8e950cf70b78456b3802d2b65d1f6d71a196946a06264b97f60bdc057b6f376e191559a78584d shards-0.8.0.tar.gz
+3865d9b78a4ec23c774b3cc345a623edeb5b42f4b4a119a3d8816b78263ef57fd474ffa57a3fbbed8633cf952d8bcb8d016e3c9b528eae6f79aec4636a11660f minitest.cr-0.4.0.tar.gz"
diff --git a/community/shards/makefile-install.patch b/community/shards/makefile-install.patch
deleted file mode 100644
index 953a321176e..00000000000
--- a/community/shards/makefile-install.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 92bca3f71124749e80fb7a41918a90287681785d Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Wed, 28 Mar 2018 00:42:00 +0200
-Subject: [PATCH] Makefile: Add install rules
-
-Upstream-Issue: https://github.com/crystal-lang/shards/pull/197
----
- Makefile | 19 +++++++++++++++++++
- README.md | 8 +++++---
- 2 files changed, 24 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0440a4b..4acf4d3 100644
---- a/Makefile
-+++ b/Makefile
-@@ -4,6 +4,11 @@ VERSION := $(shell cat VERSION)
- OS := $(shell uname -s | tr '[:upper:]' '[:lower:]')
- ARCH := $(shell uname -m)
-
-+DESTDIR := /
-+PREFIX := /usr/local
-+BINDIR := $(DESTDIR)$(PREFIX)/bin
-+MANDIR := $(DESTDIR)$(PREFIX)/share/man
-+
- ifeq ($(OS),linux)
- CRFLAGS := --link-flags "-static -L/opt/crystal/embedded/lib"
- endif
-@@ -12,6 +17,7 @@ ifeq ($(OS),darwin)
- CRFLAGS := --link-flags "-L."
- endif
-
-+MANPAGES := $(wildcard src/man/*.[1-8])
- SOURCES := $(wildcard src/*.cr src/**/*.cr)
- TEMPLATES := $(wildcard src/templates/*.ecr)
-
-@@ -58,3 +64,16 @@ test_unit:
- test_integration: all
- $(CRYSTAL) run test/integration/*_test.cr -- --parallel=1
-
-+.PHONY: install
-+install: install-bin install-man
-+
-+.PHONY: install-bin
-+install-bin: bin/shards
-+ mkdir -p $(BINDIR)
-+ cp bin/shards $(BINDIR)/
-+
-+.PHONY: install-man
-+install-man:
-+ mkdir -p $(MANDIR)/man1 $(MANDIR)/man5
-+ cp $(filter %.1,$(MANPAGES)) $(MANDIR)/man1/
-+ cp $(filter %.5,$(MANPAGES)) $(MANDIR)/man5/
diff --git a/community/shards/use-git-bare-instead-of-mirror.patch b/community/shards/use-git-bare-instead-of-mirror.patch
deleted file mode 100644
index fef88e5a7ec..00000000000
--- a/community/shards/use-git-bare-instead-of-mirror.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From 3a64a76b495708a7f3bf7969e85b26817e094cc8 Mon Sep 17 00:00:00 2001
-From: Julien Portalier <julien@portalier.com>
-Date: Tue, 12 Dec 2017 10:19:44 +0100
-Subject: [PATCH] Fix: use git --bare instead of --mirror
-
-Patch-Source: https://github.com/crystal-lang/shards/commit/3a64a76b495708a7f3bf7969e85b26817e094cc8
-
---- a/src/resolvers/git.cr
-+++ b/src/resolvers/git.cr
-@@ -178,7 +178,7 @@
-
- private def clone_repository
- Dir.mkdir_p(Shards.cache_path) unless Dir.exists?(Shards.cache_path)
-- run "git clone --mirror --quiet -- #{FileUtils.escape git_url} #{dependency.name}",
-+ run "git clone --bare --quiet -- #{FileUtils.escape git_url} #{dependency.name}",
- path: File.dirname(local_path)
- rescue Error
- raise Error.new("Failed to clone #{git_url}")