aboutsummaryrefslogtreecommitdiffstats
path: root/community/sheldon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sheldon/APKBUILD')
-rw-r--r--community/sheldon/APKBUILD41
1 files changed, 25 insertions, 16 deletions
diff --git a/community/sheldon/APKBUILD b/community/sheldon/APKBUILD
index df908ae2c4b..646c3d42b41 100644
--- a/community/sheldon/APKBUILD
+++ b/community/sheldon/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=sheldon
-pkgver=0.6.6 # TODO: Enable system libgit2 with next update
-pkgrel=1
+pkgver=0.7.4
+pkgrel=0
pkgdesc="Fast, configurable, shell plugin manager"
url="https://github.com/rossmacarthur/sheldon"
-arch="aarch64 armhf armv7 ppc64le x86 x86_64" # blocked by rust/cargo
+arch="all"
license="MIT OR Apache-2.0"
makedepends="
cargo
+ cargo-auditable
curl-dev
libgit2-dev
libssh2-dev
@@ -18,29 +19,38 @@ subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
"
-source="https://github.com/rossmacarthur/sheldon/archive/$pkgver/sheldon-$pkgver.tar.gz
- $pkgname-9aa06fd-fix-tests.patch::https://github.com/rossmacarthur/sheldon/commit/9aa06fdd5cb284daae8c48648d614e3823f3f9f3.patch
- "
+source="https://github.com/rossmacarthur/sheldon/archive/$pkgver/sheldon-$pkgver.tar.gz"
+options="net"
-export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
-export CARGO_PROFILE_RELEASE_LTO="true"
-export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
-export CARGO_PROFILE_RELEASE_PANIC="abort"
+case "$CARCH" in
+# FIXME: with libgit2-1.7 this segfaults in a specific test, but works fine at runtime
+arm*|x86) options="$options !check" ;;
+esac
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
export LIBSSH2_SYS_USE_PKG_CONFIG=1 # use system libssh2
prepare() {
default_prepare
# Build against system libgit2.
- # XXX: Disabled for now since libgit2 1.4.X is not supported.
- #sed -i 's/"vendored-libgit2"//' Cargo.toml
+ sed -i 's/"vendored-libgit2"//' Cargo.toml
+
+ # Rust target triple.
+ local target=$(rustc -vV | sed -n 's/host: //p')
+
+ # Build against system-provided libs
+ mkdir -p .cargo
+ cat >> .cargo/config.toml <<-EOF
+ [target.$target]
+ git2 = { rustc-link-lib = ["git2"] }
+ EOF
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
check() {
@@ -64,6 +74,5 @@ package() {
}
sha512sums="
-95ac78ece52786cbfabe395c9c934ed3aa2e59e1101838a129ac11338ad88af24f8142ccc4038c0fbf1620e255f9846655cbe2ac2cb604f6f782efa8b95ede09 sheldon-0.6.6.tar.gz
-49b8319cce1452f73c2b3e889d330efc1dd2f3d634433f88bbaa094d1ea30d819b0e5fd24320ccfb06160de87e9e04fc0e90dbdc89a4adea7c40d90390fbdfde sheldon-9aa06fd-fix-tests.patch
+a07d7ed080fc55f5deebff12952148b14d14d6d46d02bff2e9f4d1e95e2390d7cefc4c5f7b1c28f1f8861f5999fb83141a01c42aaab2273a43d00104a0a1f70f sheldon-0.7.4.tar.gz
"