aboutsummaryrefslogtreecommitdiffstats
path: root/community/shfmt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shfmt/APKBUILD')
-rw-r--r--community/shfmt/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/shfmt/APKBUILD b/community/shfmt/APKBUILD
index c46e0407dd3..684c938040e 100644
--- a/community/shfmt/APKBUILD
+++ b/community/shfmt/APKBUILD
@@ -1,22 +1,27 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=shfmt
-pkgver=3.1.1
-pkgrel=0
+pkgver=3.8.0
+pkgrel=2
pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
url="https://mvdan.cc/sh"
arch="all"
license="BSD-3-Clause"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz
- fix-tests-32bit.patch"
+makedepends="go scdoc"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
builddir="$srcdir/sh-$pkgver"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build \
- -ldflags "-w -X main.version=$pkgver-$pkgrel" \
+ -ldflags "-X main.version=$pkgver-$pkgrel" \
-v \
./cmd/shfmt
+ scdoc < cmd/shfmt/shfmt.1.scd > shfmt.1
}
check() {
@@ -25,7 +30,9 @@ check() {
package() {
install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt
+ install -Dm644 shfmt.1 "$pkgdir"/usr/share/man/man1/shfmt.1
}
-sha512sums="3cfca494b1c3d87b7b5cf6435909637ee6e15147fe35a1f628a1c9f127c884efa4aae9e2e1dec989ff6a32cbad08cea925c6c427f9fe7ebe41333326d1ea747c shfmt-3.1.1.tar.gz
-dcf910ee55f41a4b14ff78554103a8913820315975246bb2ba387a3ae872cbda4ec5082741e3bde8161daa1a61ef3c419f26db35c26d8a75d69803b3ab63352b fix-tests-32bit.patch"
+sha512sums="
+fbeba1883f9458c480663c31d51beaffb780205f5251cae956f6582d494109e21e062e444f7436db220fb647e833ec48498fa1f75daa7fa7ec88ba1f564d4213 shfmt-3.8.0.tar.gz
+"