aboutsummaryrefslogtreecommitdiffstats
path: root/community/shfmt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shfmt/APKBUILD')
-rw-r--r--community/shfmt/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/shfmt/APKBUILD b/community/shfmt/APKBUILD
index 6412cb7021a..684c938040e 100644
--- a/community/shfmt/APKBUILD
+++ b/community/shfmt/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=shfmt
-pkgver=3.3.1
-pkgrel=1
+pkgver=3.8.0
+pkgrel=2
pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
url="https://mvdan.cc/sh"
arch="all"
@@ -12,12 +12,16 @@ subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
builddir="$srcdir/sh-$pkgver"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build \
- -ldflags "-w -X main.version=$pkgver-$pkgrel" \
+ -ldflags "-X main.version=$pkgver-$pkgrel" \
-v \
./cmd/shfmt
- scdoc < cmd/shfmt/shfmt.1.scd | gzip > shfmt.1.gz
+ scdoc < cmd/shfmt/shfmt.1.scd > shfmt.1
}
check() {
@@ -26,9 +30,9 @@ check() {
package() {
install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt
- install -Dm644 shfmt.1.gz "$pkgdir"/usr/share/man/man1/shfmt.1.gz
+ install -Dm644 shfmt.1 "$pkgdir"/usr/share/man/man1/shfmt.1
}
sha512sums="
-f3640275577b3c7ab2130efe54435fd4ae6f1c8e59d516d09575f3692f4489572600f4a0671914bcc14d2f66f9849f312b586d4ec97618ca2c5bfec9ab278ee1 shfmt-3.3.1.tar.gz
+fbeba1883f9458c480663c31d51beaffb780205f5251cae956f6582d494109e21e062e444f7436db220fb647e833ec48498fa1f75daa7fa7ec88ba1f564d4213 shfmt-3.8.0.tar.gz
"